Cannot get x11vnc to run on BBB Rev A5B.


I am a new BeagleBone Black user. I have a Rev A5B version with the bone-debian-8.2-tester-2gb-armhf-2015-11-12-2gb.img installed.
I do not have a micro HDMI to VGA adapter yet and I wanted to try getting VNC working between the BBB and a laptop.

I have apt-get installed x11vnc after ‘apt-get update’ and ‘apt-get upgrade’ and ‘apt-get dist-upgrade’, and I am trying to get x11vnc running.


root@beaglebone:~# x11vnc -display :0 -forever


debian@beaglebone:/root$ x11vnc -diplay :0 -forever

I get:

18/01/2016 04:02:54 x11vnc version: 0.9.13 lastmod: 2011-08-10 pid: 16480
18/01/2016 04:02:54 XOpenDisplay("") failed.
18/01/2016 04:02:54 Trying again with XAUTHLOCALHOSTNAME=localhost …
18/01/2016 04:02:54
18/01/2016 04:02:54 *** XOpenDisplay failed. No -display or DISPLAY.
18/01/2016 04:02:54 *** Trying “:0” in 4 seconds. Press Ctrl-C to abort.
18/01/2016 04:02:54 *** 1 2 3 4
18/01/2016 04:02:58 XOpenDisplay(":0") failed.
18/01/2016 04:02:58 Trying again with XAUTHLOCALHOSTNAME=localhost …
18/01/2016 04:02:58 XOpenDisplay(":0") failed.
18/01/2016 04:02:58 Trying again with unset XAUTHLOCALHOSTNAME …
18/01/2016 04:02:58

18/01/2016 04:02:58 ***************************************
18/01/2016 04:02:58 *** XOpenDisplay failed (:0)

*** x11vnc was unable to open the X DISPLAY: “:0”, it cannot continue.
*** There may be “Xlib:” error messages above with details about the failure.

Some tips and guidelines:

** An X server (the one you wish to view) must be running before x11vnc is
started: x11vnc does not start the X server. (however, see the -create
option if that is what you really want).

** You must use -display , -OR- set and export your $DISPLAY
environment variable to refer to the display of the desired X server.

  • Usually the display is simply “:0” (in fact x11vnc uses this if you forget
    to specify it), but in some multi-user situations it could be “:1”, “:2”,
    or even “:137”. Ask your administrator or a guru if you are having
    difficulty determining what your X DISPLAY is.

** Next, you need to have sufficient permissions (Xauthority)
to connect to the X DISPLAY. Here are some Tips:

  • Often, you just need to run x11vnc as the user logged into the X session.
    So make sure to be that user when you type x11vnc.
  • Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
    file may be accessed. The cookie file contains the secret key that
    allows x11vnc to connect to the desired X DISPLAY.
  • You can explicitly indicate which MIT-MAGIC-COOKIE file should be used
    by the -auth option, e.g.:
    x11vnc -auth /home/someuser/.Xauthority -display :0
    x11vnc -auth /tmp/.gdmzndVlR -display :0
    you must have read permission for the auth file.
    See also ‘-auth guess’ and ‘-findauth’ discussed below.

** If NO ONE is logged into an X session yet, but there is a greeter login
program like “gdm”, “kdm”, “xdm”, or “dtlogin” running, you will need
to find and use the raw display manager MIT-MAGIC-COOKIE file.
Some examples for various display managers:

gdm: -auth /var/gdm/:0.Xauth
-auth /var/lib/gdm/:0.Xauth
kdm: -auth /var/lib/kdm/A:0-crWk72
-auth /var/run/xauth/A:0-crWk72
xdm: -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
dtlogin: -auth /var/dt/A:0-UgaaXa

Sometimes the command “ps wwwwaux | grep auth” can reveal the file location.

Starting with x11vnc 0.9.9 you can have it try to guess by using:

-auth guess

(see also the x11vnc -findauth option.)

Only root will have read permission for the file, and so x11vnc must be run
as root (or copy it). The random characters in the filenames will of course
change and the directory the cookie file resides in is system dependent.

I have looked at some tutorial pages on the web, which include commands to point x11vnc to an authority file, like:

x11vnc -bg -o %HOME/.x11vnc.log.%VNCDISPLAY -auth /var/run/lightdm/root/:0 -forever

The /var/run/lightdm directory does not exist on my BBB. Any thoughts on how to get this working?