Cannot install anything after failed upgrade on BeagleBone Black

Hello:

I am a newbie trying to develop a touchscreen application using a Beaglebone Black.

I was trying to install tightvncserver and first did a sudo apt-get upgrade

This took a lot of time and had some errors.

Subsequently things have gone wrong and I really cannot install anything. I have tried doing sudo apt --fix-broken install and that does not work too.

I would appreciate if anyone can give me any guidance, I am new to Linux (below please find a screen capture of my error messages).

Thank you in advance.
Edul

On your BeagleBone Black, just run:

sudo apt purge libtiopencl1

Regards,

Dear R C Nelson:

Thank you for your prompt response.

I did what you suggested however I still get the same error. Here’s what I see.

Thank you

debian@beaglebone:~$ sudo apt purge libtiopencl1
[sudo] password for debian:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package ‘libtiopencl1’ is not installed, so not removed
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
ti-opencl : Depends: libtiopencl1 (= 01.01.15.03-git20180817.2-0rcnee4~stretch+ 20180817) but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or speci fy a solution).
debian@beaglebone:~$

ah, it's also ti-opencl (its' for the x15, not used by the beagles..)

sudo apt purge ti-opencl

Regards,

Dear Robert:

Thank you very much for your prompt responses.

The second command worked and now my system is stable and I am able to install programs.

Have a great weekend and thank you again!

Edul