Cannot load device tree overlay at startup

Hello there,
I am using a custom build kernel using the script from Mr Nelson (https://github.com/RobertCNelson/bb-kernel.git). I am facing problems with loading a device tree overlay for dvi cape at startup. I was abble to succesfully load the overlay using echo BB-BONE-DVID-01 > slots when running already. I tried sifferent methods for loading the device tree at startup.

I tried creating uEnv.txt in /boot/ directory that contains:

`

enable systemd

optargs=quiet init=/lib/systemd/systemd

enable dvi

cape_enable=capemgr.enable_partno=BB-BONE-DVID-01

`

This havent worked so i tried editing /etc/default/capemgr with:

`
CAPE=BB-BONE-DVID-01

`

But that also did not help, the dts is not loading at startup.
I would aprichiate any hints on this case. Is there any step I could possibly miss when loading device trees at startup?
I am using debian wheezy.

dmesg | grep cape

Regards,

This is the grep cape from the debug console when booting.
http://pastebin.com/RSjGfuce
Ill pase the grep cape from dmesg tommorow morning if theres anything missing, the board was left at university.

This is the output of dmesg:
https://pastebin.com/DPgdsuR4

There is no sign of BB-BONE-DVID-01 loading, but only BB-BONE-DVID-02, and I am not loading this overlay anywhere. Are there any other places I can check for capes that are loaded at startup? I feel the BB-BONE-DVID-02 is loaded by default somehow.

W dniu 2015-03-31 o 15:23, Robert Nelson pisze:

Hi,
Can you try the following in uEnv.txt
``optargs=capemgr.enable_partno=BB-BONE-DVID-01

First thing in the morning.

Can you pass many parameters to optargs, so I can still use systemd?

Same thing :confused:

Hi there,
Any other hints maybe? I still havent resolved this :.

Editing /etc/default/capemgr worked for me, can you try creating uenv.txt in /boot/uboot ?

Ill try replacing the uEnv.txt, will let know as soon as I do.

Hello,
Moving uEnv.txt havent solved the issue: Any other thoughts?

I am too seeing this issue on the latest 4.1 kernel.

This is a custom cape that loads fine echoing direct to the slot but when I add to the /etc/default/capemgr file nothing happens.

Nothing in the log at all for it.

Lee

The script that uses /etc/default/capemgr needs to be patched for v4.1.x

Regards,