Cannot update Kernel on BBAI by running update_kernel.sh

Hi,
I’m trying to update the kernel on a BBAI alpha board.
Went to /opt/scripts/tools/ and ran update_kernel.sh

Getting the below output…

root@beaglebone:/opt/scripts/tools# sudo ./update_kernel.sh
Machine: [BeagleBoard.org_BeagleBone_AI]
No arg for -k option
Usage: /usr/sbin/update-initramfs [OPTION]…

Options:
-k version Specify kernel version or ‘all’
-c Create a new initramfs
-u Update an existing initramfs
-d Remove an existing initramfs
-t Take over a custom initramfs with this one
-b directory Set alternate boot directory
-v Be verbose
-h This message

Did not see BeagleBoard.org_BeagleBone_AI as an option in get_device()

LJ

Run git pull n that directory.

yup. Tried that. No luck.

Already up-to-date.

yup. Tried that. No luck.

Already up-to-date.

It is on the wrong branch by default.

Try:

git remote update
git checkout -b rcn-master origin/master

Is it possible for me to get hands on a Beaglebone AI? I would be very interested in trying it out.

Haha Alex, me too I want the BeagleBone AI. I think we haven’t the choice, we must wait for official release.

Me too.

Me too :slight_smile:

Regards