Can't activate UART on custom BBB board

Hi !
I made a card which is the exact copy of the BBB architecture (same CPU, same RAM chip, same power supply) but without HDMI and flash memory chips (to meet size requirements). With Robert Nelson’s advices, I’ve build a Debian Jessie image without board ID checking and I succeed in booting on it (thanks again Robert !)

Now I’d like to activate UART1 but I can’t. I’ve tried to install overlays with

https://github.com/beagleboard/bb.org-overlays

and put at the end of /boot/uEnv.txt

capemgr.enable_partno=BB-UART1

like I did with a real BBB but the answer of

dmesg | grep tty

is

[ 0.000000] Kernel command line: console=ttyO0,115200n8 quiet root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable
[ 0.000308] WARNING: Your ‘console=ttyO0’ has been replaced by ‘ttyS0’
[ 3.842582] 44e09000.serial: ttyS0 at MMIO 0x44e09000 (irq = 155, base_baud = 3000000) is a 8250
[ 3.843036] console [ttyS0] enabled
[ 7.687412] systemd[1]: Created slice system-serial\x2dgetty.slice.
[ 7.704938] systemd[1]: Created slice system-getty.slice.

Do you have any idea what’s wrong ?
Thanks