Can't enable ADC in my own DTB

In my DTS, I added the fragment from the bb.org-overlay repo like this:

    fragment@7 {
        target = <&tscadc>;
        __overlay__ {

            status = "okay";
            adc {
                ti,adc-channels = <0 1 2 3 4 5 6>;
                ti,chan-step-avg = <0x16 0x16 0x16 0x16 0x16 0x16 0x16>;
                ti,chan-step-opendelay = <0x98 0x98 0x98 0x98 0x98 0x98 0x98>;
                ti,chan-step-sampledelay = <0x0 0x0 0x0 0x0 0x0 0x0 0x0>;
            };
        };
    };

I originally enabled only channels 0, 1, and 2, and didn't have any of the chan-step lines, but when that didn't work I tried to make it more like the supplied BB-ADC.

I have a bunch of other stuff in the DTS, like enabling the PRU and some audio stuff. When I load the overlay, the PRU is enabled, but the ADC is not.

If I then load the BB-ADC, the ADCs work correctly.

I'm using the make && make install from bb.org-overlay to rebuild my DTS.

Is this something to do with the DTB caching there was once upon a time, or does the Makefile take care of that?

For completeness, this is the DTB fragment I used to have:

    fragment@7 {
        target = <&tscadc>;
        __overlay__ {

            status = "okay";
            adc {
                ti,adc-channels = <0 1 2>;
            };
        };
    };

Thanks,

To answer my own question, I think yes, it's the initrd caching going on/collision with existing filename. I changed the name of the file, and now it seems to be working (because there's no name conflict in intiramfs).