Can't get BBB to boot

I downloaded debian image from here
I used Win32 Disk Imager to write it to an SD card.

If I apply power while holding the Boot switch, It blinks for a while then has a Kernal Panic - not syncing: hung_tasks: blocked tasks (I think its mmcqd)

If I boot without holding the Boot switch. It goes into a desktop with a message saying that it is a Temporary desktop and that it’s flashing.
That takes about half an hour, then it shuts down.
When I apply power it tries to start the desktop, then shows an error about PHY library not found, and ETH0 - not found on slave 1.

Please help, I’ve never been able to boot this thing. I’ve tried several times already.

That’s the same my board is doing (see also my question in this forum ‘How should beaglebone black “start screen” look like?
May I asked what your board did when you started it with out of the box Angstrom? Did you get a working desktop?
Where did you get you board from? - element14?



I just flashed Debian a 2nd time. And this time I removed the SD card after flashing and suddenly it worked.
I hope it is as simple as that.

good luck


I don’t know if you follow anymore or if you already gave up.
I just wanted to point out that since March 2nd new images are available. I overlooked it myself until yesterday.
The one for eMMC is not directly on the latest image site, but here (for BBB Rev C). Boot switch seems to work like expected. You can leave the SDCard in the slot after reboot.