Can't mount Windows share -- No 'cifs' package for BBB Angstrom?

I tried to do a mount -t cifs and got an error stating cifs filesystem was unknown.

So I tried opkg install cifs, opkg install cifs-utils, and opkg install smbfs.
All failed stating “unknown package”.

Is it possible somehow to mount Windows shares on the BBB?


Did you try installing

When I have problems finding the package I am sure should exist, I go to and search for what I think I need. The last I was searching for was lrzsz, I use zmodem transfers quite a lot, but understand not having it in the default install.

I didn’t try that because I didn’t know about that Feeds website. :slight_smile:
I have now pulled that down and installed it, rebooted, tried my mount again and now get a different error.

mount error: cifs filesystem not supported by the system
mount error(19): No such device

I see that’s a very popular error msg on Google.

modprobe cifs says: Module cifs not found.

Do I need to install one of the kernel-module-cifs packages on the Feeds website also?

I assume that it needs a kernel package, but I didn’t try to figure it out myself. Did you get the solution working?

I didn’t know what was needed and didn’t want to blow up the image (since I have other stuff ported to the BBB and
not backed up anyplace yet).

Basically I got disgusted and just gave up.


I just figured out that the kernel wasn’t even built with CIFS support as a module, so I don’t think I can mount a share from windows without rebuilding the kernel.

I figured this out by looking at the current kernel running configuration with this command and it’s result.

root@beaglebone:~# zcat /proc/config.gz | grep -i CIFS

CONFIG_CIFS is not set

I’m attempting to build a new kernel with the 3.11-rc right now, just to see if perhaps my USB crash problems go away with the latest kernel, so I’ll probably include CIFS support in my kernel.


When I click on the link I get “Page not found”.

Has anybody found a solution to mount a cifs share on BBB?

is there any way to mount windows share on angstrom?