Can't reach

I tried to connect BBB on USB port(AM3358). The files are opening, i can reach the files inside BBB but cant ping the or cant connect on Putty with SSH. If its possible its okay for me to reset to the fabrication settings. Any suggestions?


Try to ping beaglebone.local via terminal/command prompt

It says “Ping request could not find host beaglebone.local. Please check the name and try again.”

Hello @Gulsum_Toker ,

Seth here. What image are you using? From this forums or on the website?

These images: - latest-images ?

Or these: Debian 11.x (Bullseye) - Monthly Snapshots ?

Anyway…I have tried some images from this forum recently. They work. I will try ping soon on PuTTY to test things. Until then, please use these commands to give some idea as to where you are in images…

cat /etc/dogtag
uname -a

Thank you. Oh! Also, if you cannot sign in and are just using the UART0 header pins for debugging, an output of the boot log will be helpful for some people too!


P.S. I will sign in and tell you my image ideas from cat and uname and ping.

uname -a: Linux BeagleBone 5.10.145-ti-r55 #1bullseye SMP PREEMPT Tue Dec 6 23:59:06 UTC 2022 armv7l GNU/Linux

cat /etc/dogtag: Debian Bullseye IoT Image 2023-01-02

Also. ping works just fine…

Thank you Seth. I am not knowledgeable about BBB or Linux actually just tried to figure out and connect on PuTTY so I can check something. I can ping on ubuntu but not on Windows, do you have any comments about this?
About commands you tell about, where should I use them?

It might be Windows firewall, or other installed firewall causing you problems.
Either that or Windows is not recognising the BBB USB ethernet device, or it is setting a different IP address.

You could try running ipconfig /all in Windows to list all of the devices and IP addresses. See if the USB ethernet shows up and what IP address it is running.

Oh, and also if you have an active VPN link running, that might be redirecting your IP traffic over that and not reaching the BBB

1 Like

Is your bb connected to ethernet?

Hello @Gulsum_Toker ,

Seth here. I do not have comments on the Windows interference you are seeing. Like @benedict.hewson says, it could very well be a Firewall issue or some type of Windows USB issue w/ their proprietary USB interface. What does the device manager show in Windows? I mean…does Windows show the BeagleBone Black in question as a type of specific device?

For instance:

Device Manager --> Portable Devices --> BeagleBone should show some info…

Also USB-NCM is a thing to view on Windows. What version are you running for Windows?


P.S. Oh and the commands should be on the terminal in PuTTY when run…

I don’t know the IP of the ethernet port so I cant connect on ethernet

Actually i know that the beagle bone has configurated to a private server so i connect that servers VPN but still cant ping on Windows

Follow these steps:

  1. Disconnect all cables from BB
  2. Connect ethernet cable + usb-c to usb to your computer/laptop
  3. Launch command prompt as admin
  4. Options:

ping debian@
ping beaglebone.local
ping beaglebone-2.local

if you are able to ping I recommend PUTTY to ssh.

  1. Press reboot ONCE and try again if it didn’t work. Sometimes it can be your cable too.
$ ip route

For some reason mine has and

also when you ssh into it

$ssh debian@

or try

$ssh debian@

Password when you connect is temppwd

When you connect to it with USB cable you should see it connect as a “drive”.

If you do see it as a drive your board is running properly.

If not burn a new image onto the SD card. Besure to eject the the card when it is done burning this way your file will be completely transferred.

One solid blue and the opposite side 1 will heartbeat after it boots successfully. I don’t push any buttons, just pull the USB connector out. If the heartbeat is not active its not running.

Not sure what is up with mine, I am in a VM so that might be the problem with connectivity using USB / ssh.

What is working every time is the connection using gtkterm and usb cable
You can check if the ssh service is running once you connect using terminal

$systemctl status sshd

Not sure why I thought you were using a pocket beagle, sorry my post is related to that board.

It shows as the picture i attached.

It didn’t work :frowning: Im sure about my cable

Hi @Gulsum_Toker,

Do you have a monitor you can connect your BB to? If so, please connect a monitor to your bb and the usb-c to usb connection on your laptop/computer, to see if there’s anything helpful on the screen.

@Gulsum_Toker ,

Do you think you might have an older model of PuTTY on your Win desktop? I have 0.76 on mine and it works. Do you have any other pins allocated to modules on the BBB?

Also, that is exactly what shows in Device Manager --> Portable Devices --> BeagleBone for me.

So, you are using Enterprise instead of a local connection I am guessing here.

Network-Manager has specifics on how to connect to the BBB/Linux in theory for enterprise style set ups.


P.S. At least we know now that your BBB is pictured and available on the Device Manger in Win. Please try to update PuTTY and I will try to learn about Network Manager Enterprise connections and list a link in the near future.

Maybe try: nmcli device

You might need sudo permissions but try w/out it first.

These commands may show you info. that will help you:

nmcli -t -f STATE general
nmcli connection show --active

The first command shows the state of Network Manager.
The second command shows all active connections.

This may help you. Oh! Also…I found the examples for Network-Manager: nmcli-examples(7) — network-manager — Debian bullseye-backports — Debian Manpages

They have some good ideas there in the examples on that link.

@Gulsum_Toker ,

If those commands do not work. I understand that nmcli may not be installed.

Also, another useful tool is ip.

You can find a neat alternative to see your desktop ip ideas: ip a .

Look here for additional ideas:


P.S. I read that you are using a VPN of some sort. I am not sure about VPNs. You may have to wait around for someone else. I am sorry. I cannot find anything for SBC computers right now running Debian for VPN access but: .

It may have another name. Those are some good resources to look over.


Here: OpenVPN - Debian Wiki may give some insight as to how things are configured on your VPN, what commands to look over, and how the BBB may play a part to the config.

When i connect BB with USB cable this file appears:


@Gulsum_Toker , this is actually a first for me. I do/did/have not ever gotten those files listed when booting the BBB. That is odd to me.

What image are you running?