can't seem to get linuxcnc running on beaglebone black get errors..

I get this error when i try to run linuxcnc on beaglebone black i have tried on a windows computer and a linux setup computer get the same message on both systems
i tried from the sdcard and emmc also.
can’t seem to get an internet connection from the sdcard but was able to connect from the emmc setup
any suggestions checked a bunch of messages and tried many of the suggestions but no luck…


[1] 2073
machinekit@beaglebone:~$ LINUXCNC - 2.7.0~pre0
Application initialization failed: no display name and no $DISPLAY environment variable
Error in startup script: invalid command name “image”
while executing
“image create photo -file $f/$i.gif”
invoked from within
“if [file exists $f/$i.gif] {
return [image create photo -file $f/$i.gif]
(procedure “linuxcnc::image_search” line 7)
invoked from within
“linuxcnc::image_search linuxcnc-wizard”
invoked from within
“set logo [linuxcnc::image_search linuxcnc-wizard]”
(file “/home/machinekit/machinekit-dev/tcl/bin/pickconfig.tcl” line 31)