Can't seem to get pinmux working

Trying to enable PRUs and set P8 45,46 to output just to test some IO toggle using R30 on PRU1
OVERLAY: project-00A0.dts:

/dts-v1/;
/plugin/;
/{
compatible = “ti,beaglebone”,“ti,beaglebone-black”;
part-number = “project”;
version = “00A0”;

exclusive-use =
“P8.45”,
“P8.46”;
fragment@0 {
target = <&am33xx_pinmux>;
overlay {
bone_project_pins: pinmux_project_pins {
pinctrl-single,pins=<0x0a0 0x05 0x0a4 0x05>;
};
};
};
fragment@1 {
target = <&ocp>;
overlay {
project {
compatible = “bone-pinmux-helper”;
status = “okay”;
pinctrl-names = “default”;
pinctrl-0 = <&bone_project_pins>;
};
};
};
fragment@2 {
target = <&pruss>;
overlay {
status = “okay”;
};
};
};

/sys/devices/platform/bone-capemgr/slots:

0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
5: P-O-L- 0 Override Board Name,00A0,Override Manuf,project

From /sys/kernel/debug/pinctrl/44e10800.pinmux/pins

pin 40 (44e108a0.0) 00000008 pinctrl-single
pin 41 (44e108a4.0) 00000008 pinctrl-single
pin 42 (44e108a8.0) 00000008 pinctrl-single
pin 43 (44e108ac.0) 00000008 pinctrl-single

Just saying I would expect these to be set to 0x05 instead of 0x00,
Stranger yet, I’m sure there is some kind of non-obvious reason that in the overlay file, you reference the pin as offset 0x0a0/0x0a4 when their real offsets are 0x44310800… wait, i see it there… nevermind.
anyway should pins be showing the value of 8 instead of 5?

Ok, think I kind of maybe figured it out.
looks like the nxp hdmi interface apparently uses these pins as well… so I have to disable it…
are the HDMI and eMMC really that hard tied together?
I couldn’t find a way to disable one with out the other, or maybe I’m just an idiot.
anyway off to pull a new image, and flash to an SD card, so I can boot without eMMC. and a serial console…

Ok it works after I disabled the HDMI option cause the pins the hdmi uses shares pins with the PRU1 r30_x bits. mystery solved. I was confused because all of the remarks made about disabling the HDMI cape. I disregarded this because there was no HDMI cape listed in cape mgr.