can't ssh to BBAI after upgrading rt kernel

I also don’t see anything when I hook up a monitor and keyboard. Is there a way to boot with an SD card and switch the kernel back? Any other options? I’d like to be able to save everything that was in my home directory if possible.

If you can successfully boot from SD card, you should be able to mount
the eMMC and then copy that home directory off to the SD card.

Thanks Dennis!

This is what I ended up doing:

  1. I flashed an SD card with this image:
  2. Booted up the BBAI with the SD card in.
  3. sudo mkdir /mnt/emmc
  4. sudo mount -t ext4 /dev/mmcblk1p1 /mnt/emmc
  5. Edited /mnt/emmc/boot/uEnv.txt and switched the kernel back
  6. sudo shutdown -h now
  7. Removed the SD card
  8. Booted back up successfully from the eMMC

This post was helpful:

I had the same problem. I had messed around with uEnb.txt and made it unreadable to the OS, stopping the OS from loading. I tried the link to that version of Linux you listed, but it didn't work at all. Then, I tried a different version,( and it booted up like it should have when I held down S2. Also, on the matter of using a USB to UART cable, the manufacturer of the cable had the labels reversed. (Tx and Rx). Be aware that this might be a problem for you too. That took a while to trouble-shoot because the gobbledygook that is output to the screen is usually thought of as being just a bad baud setting.

Please keep track of which board you are discussing.

is for the Beaglebone AI whereas
is for the Beaglebone Black (and similar boards).

  The BBAI and BBB use different SoCs (with much different on-board
hardware [unlike the R-Pis which have different SoCs but same on-board
hardware, so can function with a single OS image with just a bunch of board
specific DTBs), so an image built for one is not expected to run on the
other. As I recall, the BBAI also does not have a boot-select button (a
button that hasn't, in normal use, been required on the BBB since Debian
Jessie -- if the eMMC had been flashed with a modern uBoot smart enough to
search for the SD card and transfer control)