(Clone) [Insteon Hub Pro] Flashing eMMC help

There’s no USB hub. There’s no USB. The power comes from Insteon’s power brick (I’d have to check the amperage), through its network board, and from there into the Beagleboard.

1 Like

@Calion ,

Hello…did you ever test the Insteon? I mean…was there any voltage you say that resembled 5v and a UART or I2C connection to the BBB?

I think the vdd_5v on the Cape or Host should give out 5v at 2A or a little less to power the BBB correctly. It depends too on other things.

  1. Is there enough power for the other parts of the BBB to work?
    a. Are peripherals in use or in the way of taking on too much per pin and having the pins maxed out at a specific mA?
    b. I am asking b/c I think the BBB and its pins can only handle so much output…
  2. And…
    a. Where are the schematics or diagrams and literature on these devices attached to the BBB?
    b. It would be helpful in tracking down specifics.


P.S. This is just a follow up. I know nothing about the Insteon so far. But, when plugged into the BBB, this Insteon host, powering the BBB is one thing and communicating to the BBB is another. So, I am trying here with life happening all the time. If you could, please try to find out anything and I may be able to give more feedback. Also, other people are more knowledgeable than me on specifics if things get too complicated to me.

did you ever test the Insteon? I mean…was there any voltage you say that resembled 5v and a UART or I2C connection to the BBB?

No, and I’m unsure how to go about doing so. I have never pulled the connector off, and have no idea what the pinouts are.

Sorry, I’m not a Beaglebone hobbyist; I’m a Homebridge hobbyist trying to get Homebridge working on the Hub Pro now that Insteon has discontinued HomeKit support (and then went out of business).

Is there enough power for the other parts of the BBB to work?

Definitely. It was running flawlessly off the SD card, other than needing an occasional restart.

Are peripherals in use or in the way of taking on too much per pin and having the pins maxed out at a specific mA?

The peripheral is the network board, which is feeding power to the BB. So…no?

Where are the schematics or diagrams and literature on these devices attached to the BBB?

I don’t think schematics are available; The Hub Pro is (was; it’s discontinued, unsupported, and Insteon has closed down) a proprietary product. As for literature, there’s a user manual, but I don’t know how helpful it will be, apart from the Specifications at the end. http://cache.insteon.com/documentation/2243-222-en.pdf

However, here’s a picture of the Hub Pro: Dropbox - IMG_1151.heic - Simplify your life

Hello @Calion ,

I know this is redundant and may not prove any value but!

Have you detached the BBB off the Insteon yet? I am asking b/c of these issues:

  1. Maybe testing the Insteon with a oscilloscope could be handy.
    a. Test the pins that feed into the BBB…
    b. GND, vdd_5v, and UART or however you think it is communicating with the BBB.
  2. Once the BBB is detached, boot the BBB with your SD Card and hold down the S2 Button (the button near the USB Port) while the boot takes place and release once all your LEDs light up.
  3. Now, for flashing your SD Card to the BBB eMMC onboard the SBC, use /boot/uEnv.txt.
  4. There are a couple of lines in there about flashing the BBB.


P.S. I know things are “awkward” right now. Hence, your questioning. I wonder if it is possible to detach it. If so, reply and take those steps. It should boot off the SD Card, i.e. depending on your Image, Kernel, and developed source.

Okay, so I’ve punted and tried with a fresh SD card image…and am getting a similar problem (not exactly the same; now it only flashes heartbeat for a little while).

I can’t find the thread you’re referring to. “bealgecfg” gives no results, either on this forum or in Google.

I do not have, nor know how to use, an oscilloscope.

How do I power the BBB once I detach it?

Hello @Calion ,

Seth here. After updating the BBB, use this command: sudo beaglecfg

That will bring upon a prompt to expand your SD Card image to its full capacity. You can can scroll w/ your arrow keys on your keyboard to see what is available in that prompt.

Okay, forget the oscilloscope.

Power the BBB via Micro USB to the host via USB 2.0. So, you will need a Micro USB to USB 2.0 cable.


P.S. Then, once in the terminal, you can adjust your capacity of the SD Card via sudo beaglecfg and perform other functions in the Debian OS given by beagleboard.org. Which image are you running?

  1. cat /etc/dogtag
  2. uname -r

The BBB won’t update. That’s the whole problem.

I unplugged the BBB from the modem, but the only ports I see besides the Ethernet port is a dual USB-A port. Plugging a USB-A to USB-A cord between the BBB and a 5w charging block, in either port, did nothing.

The AM3358 Debian 10.3 2020-04-06 4GB SD IoT. Is that the right one?

Hey, I never noticed the ““Flasher” Debian images.” Maybe the problem is that I’ve been using the wrong image!

Oh. Okay…

@Calion ,

So, can you get to a terminal at all w/ the current config. of your BBB? A photo may prove useful.

There should be a Micro USB port on the BBB too, i.e. not just a USB Port.


Oh! Also, there is a couple links in this forum for Bullseye and older Buster images.


P.S. There is a new way to update/upgrade images from apt now. I suggest you get an image from one of these links:

  1. Debian 11.x (Bullseye) - Monthly Snapshots
    a. There are links for SD Card images.


P.S. Send a photo of the front of the board and the back of the board if you can. You may be able to use the Serial header on the board to get into a terminal.

Here’s the pictures you asked for. I tried flashing it with AM3358 Debian 10.3 2020-04-06 4GB SD IoT, but after leaving it overnight and restarting, the light is solid green and it’s not showing up on the network.

Neat board… That is NOT a BeagleBone Black… Looks like a clone built by Insteon for their hub…

Since i see no HDMI, you can get into the serial terinal via this connector:

Here is the serial adapter… (you’ll need to solder a 1x5 header on it…)


Since we don’t have access to Insteon’s schematic… I can’t confirm of this is even compatible…

an then… of course we don’t have access to what ever they preinstalled…


1 Like

I don’t think that serial access will help at this point. I’ve wiped the SD card and started over, and when I boot from the SD card using the standard 4GB image, everything works fine and I can access it over Ethernet. It just won’t flash completely (it seems to flash partially, meaning that I’ve lost the initial installation). Unless having access to the serial terminal might allow me to get it to flash?

But that it’s not a true BBB might explain why some revisions of this board will flash, and some won’t. Looks like I have one that won’t. Hub Pro 2243 Question · Issue #63 · kuestess/homebridge-platform-insteonlocal · GitHub

Which doesn’t bother me—leaving the SD card in is no big loss—but what does bother me is that I have to force it to boot from the SD every time it loses power (right?). Is there any way to convince it to always boot from SD without having to hold down S2?

Based on that, it looks to be a 2GB eMMC, so when you try to flash it, make sure you are using a “2GB” image, and not a “4GB” image, as that will not fit…

Those would be the “minimal” images here: https://forum.beagleboard.org/tag/bbbio_debian


Oh, geez, how obvious. I’ll give it a try! Thanks!

Okay, so when I try to boot from that, the light comes on solid for several seconds, and then goes out. And the device isn’t showing up on the network.

1 Like

Okay, the next step would be to connect to that 5 pin serial header, then we can see what the image is trying to do…


1 Like

Thanks. I think I’ll just stick with booting from the SD card for now. Maybe I can follow these instructions to make it boot from the SD by default. Unless someone knows a better way?

if you can boot a standard microSD image, then the flasher would also work…

It’s up to you… without wiring up the serial console you’ll just keep on guessing…


Hm. Looks like you’re right. Why are you right? Why does changing the boot flag not work if it won’t flash?

Let me know when you have a serial access to the board to debug…