Cloud9 IDE will not start

I just recently got the BeagleBone Black, and I wanted to learn more about it so I plugged it into the computer with the provided cable. At first, it worked quite nicely, and I could easily access and I went through the tutorial from the BeagleBoard for the Cloud9IDE, and it all seemed to work nicely. I wanted to get back to the starting page, so I (very stupidly) unplugged the BeagleBoard without powering it down, and then plugged it back in. Still worked. Problem now is that when I tried accessing the sample programs that I saw on the first run (blinkled.js, among others), they had disappeard. So, I figured maybe I plugged it in wrong (I’m a newbie…sorry for my ignorance) and did the same thing again. This time, still worked, but same thing. So I figured unplugging it again wouldn’t work, so this time I just messed around with it and made the sample program myself (I am using “Bad to the Bone” beaglebone guide as my reference). However, now I was unable to save the program (it just wouldn’t let me). At this point, I was rather upset, and so I unplugged it again to just put it to the side for a while. I tried it again not too long after, and the Cloud9 IDE wouldn’t even start. the does open up, but when I try to access, it gives me

Unable to connect

Firefox can’t establish a connection to the server at

The site could be temporarily unavailable or too busy. Try again in a few
If you are unable to load any pages, check your computer’s network
If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web.

I have played around with it for a while now, reloading the page multiple times, pressing the reset button (although I don’t know what the other two buttons are for)…it still won’t work.

The only other thing that I noticed was that it seems to get warm when plugged in. I don’t know if that is normal, but I figured I’d mention it.

Any advice would be appreciated.

Best Wishes,
Happy Modding,


how would i do that from a mac system, that terminal program doesn’t have mac systems under it’s compatibility. also is this a problem that i will keep having? i don’t feel like that fix is really explaining the problem very well, like why, or how to avoid it from happening again.

ok i got it. for mac users.

  1. open your terminal app. it’s in your applications folder then utilities
  2. go to the top drop down menu " shell ", select " new remote connection "
  3. highlight secure shell (ssh)
  4. in the very bottom line type " ssh -p 22 root@ "
  5. a new window will appear and ask you " Are you sure you want to continue connecting (yes/no)? " type " yes " and press enter
  6. next you will be asked for a password " root@’s password: " leave blank and press enter.
  7. your next prompt will be " root@beaglebone:~# " type " mkdir /var/lib/cloud9 " and press enter
  8. eject your beaglebone and reset the power. after booting back up you should be back in buisness.

now for the explanation. after going threw the automated walk threw in cloud9 it erases the folder " /var/lib/cloud9 " but this is an important folder that you need in order to use cloud9. so what your doing is using terminal to make an ssh connection to the beaglebone(1-6). this is basically a way to use the command line on the beaglebones terminal(like dos on a windows machine) from a remote computer.
then you create a new folder in place of the one that was deleted(7). mkdir = make directory
after that you just have to restart your beaglebone and it’s like it was never gone. i hope this helps everyone else. this stressed me out for the last two days.


If you have Google Chrome, you can also use Secure Shell 0.8.19 and SSH into it. More info on it can be seen here:

When I try this I get the following:

ssh_exchange_identification: Connection closed by remote host

[Process completed]

What do I do? Getting this Beaglebone to work has been a nightmare.

Thanks for the help.

Are you using a MAC as well?

Yes. I have a linux machine as well, and they seem to be having the same problems. I even tried just manually adding the /var/lib/cloud9 folders into the beaglebone, ejected, reset, and attempted it again (from my Mac) but had the same issue. Trying to use GateOne (from any machine) gives me the same error.

I’m not really sure, I’ve never encountered that problem before. Have you tried re-flashing your BBB? Sorry, I wish I could be more of a help.