Code Sourcery G++ Lite installation on Ubuntu no tworking!

Hi everyone,

Firstly thanks for taking the time to read this.

I'm having a little trouble with the Code Sourcery G++ Lite
installation on Ubuntu.

I followed the getting started guide which said for the Graphical
Interface installation just follow the steps pressing the 'Next'
button.

Once the installation is complete, to test my paths are setup
correctly use the following command;

# arm-none-linux-gnueabi-g++

and I should get an output of;

# arm-none-linux-gnueabi-g++: no input files

but I am getting;

# bash: arm-none-linux-gnueabi-g++: command not found

In the setting up environment section of the getting started guide it
says for those installing from a compressed file you need to the
following;

Hi Rob.

A mate and I found the same issue when doing a graphical install in
Ubuntu (at least with the 2007q3 release; don't know what happens with
later versions of it). The only option we had was to install it
manually, per the "Getting Started" guide.

As a reference, the same graphical installer works just fine in Fedora
Core 10 and I've been able to use it per the instructions located in
the wikis.

Please, let me know if we can be of further help.

Best regards,

Alex B.

Thank you Alex. I will look into this.

Rob

Ok, here's an update on my situation, and it's still not working.

I downloaded Code Sourcery G++ compressed version.
Uncompressed it without a problem;

# bunzip2 /path/to/package.tar.bz2

Extracted it to a folder in my home directory called "CodeSourcery"

# tar xf /path/to/package.tar

Setting up the environment. I did the following as instructed by the
guide:

PATH=$HOME/CodeSourcery/sourceryg++-2008q3/bin:$PATH
export PATH

Then tested it using

arm-none-linux-gnueabi-g++

and I still get the output of

bash: arm-none-linux-gnueabi-g++: command not found

Any ideas anyone?

It works fine under Windows.

:frowning:

Ok ok, I have it working after doing some google searching!

For those who come across this problem, here is the solution. For
Ubuntu this works anyway!

Uncompress & Extract the files as shown in the Getting Started Guide.
My files were extracted to "/home/Hurdy/CodeSourcery"

Now, ignore their setting up Environment guide and use this instead.

#newpath="/home/hurdy/codesourcery/arm-2008q3/bin"

*** NOTE FOR ABOVE, CHANGE THE DIRECTORY in the " " to your
CodeSourcery directory. ****

Then paste the following:

# if [ -d "$newpath" ]; then printf "\nif [ -d \"$newpath\" ]; then\n
\tPATH=\"$newpath:\$PATH\"\nfi\n" >> ~/.bashrc; PATH="$newpath:$PATH";
fi

Now close the shell and open a new one. You can now test to see if it
has been setup properly using the following;

# arm-none-linux-gnueabi-g++

and you should see:

arm-none-linux-gnueabi-g++: no input files

This worked for me under Ubuntu. I hope this helps you too.

Hi.

Just as a small note, instead of using "bunzip2", we used:

"bizp2 -d arm-2007q3-51-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2".

Don't know if they are equivalents.

Then, we did:

"tar -xf arm-2007q3-51-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar"

And then the Path export.

Did you check the case of the letters?

The export seems fine.

Have you tried executing arm-none-linux-gnueabi-gcc by providing the
full path to it?

Best regards,

Alex B.

I have it working now thank you Alex. I think we posted at the same
time. I've also written a guide to how I've done it should others have
trouble following me.

Thank you again for your time,

Rob

Yes, we posted at the same time.

Before going the route you took (of writing directly to the .bashrc
file), I was going to check how you were exporting the environment
variable.

Anyway, it's good that you found the better answer. =)

Cheers,

Alex B.

Hehe, many thanks again Alex.

The guide I followed for setting up the paths came from:

http://ubuntuforums.org/showthread.php?t=429127

Good luck,

Rob