Compiling PM current kernel for BeagleBoard

Hello everyone!

My team and me are developing some stuff to improve power consumption in embedded systems in a university project. We are currently working with the BeagleBoard and the 2.6.32 kernel from the BeagleBoard Validation repository. Some time ago (more than a year) we compiled and tried the pm kernel from the following repository:

git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git

Everything was ok, although some features for the BB was missed, so we kept in the Validation kernel.

Nowadays we want to check again the state of the pm kernel, but we realized that the information about it in the BeagleBoard’s wikis and pages is out of date (for example http://elinux.org/OMAP_Power_Management ). No pm branch, and no omap3_beagleboard_defconfig (as in validation repository) configuration file…

So, now we have some problems and some help about them would be very appreciated:

We don’t know what’s currently the best branch from the khilman omap-pm repository to use. We used the master branch, which contains the 3.4rc4 kernel version. Is it the best to use in the BeagleBoard? Or there is any other better?.

We don’t know which config file to use. We used the omap2plus_defconfig, since we supposed it should fit any omap2 and greater board, but our kernel doesn’t boot. We tried to compile with the default config and also changing the following, in order to get the config more specific to the BB:
System Type > TI OMAP Common Features > SmartReflex Support (OMAP_SMARTREFLEX) > Enabled
System Type > TI OMAP2/3/4 Specific Features > Disabled everything but “TI OMAP3” and “OMAP3 BEAGLE Board”
Besides, we tried to compile with two different cross-compiling toolchains: A mature one, the 2010.09 version and the latest one, the 2011.09, both from Mentor Graphics (formerly CodeSourcery).

When we try to boot the kernel from the uBoot (we use the uBoot version U-Boot 2011.06-dirty (Jul 19 2011 – 17:30:34) ) we get the following:

reading uImage34rc4pm20120523_p1_2010.09

3668904 bytes read
NFS root.

Booting kernel from Legacy Image at 80000000 …

Image Name: Linux-3.4.0-rc4-00135-g2300fd6
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 3668840 Bytes = 3.5 MiB
Load Address: 80008000
Entry Point: 80008000
Verifying Checksum … OK
Loading Kernel Image … OK
OK

Starting kernel …

Uncompressing Linux… done, booting the kernel.

And then the system freezes. (Note that in other kernels more point after “Uncompressing Linux” are showed. I don’t know if this could be a clue…)

In brief, we need a how-to to compile the new pm kernel for the BeagleBoard… Any help is very appreciated.

Thank you very much in advance!
Regards.

Well, if your moving from a 2.6.32 -> 3.4-x based kernel, you need to
update your bootargs as around 2.6.36 the serial setting for
CONFIG_SERIAL_OMAP=y was renamed from "ttySx" to "ttyOx" (O as in
omap, not zero..)

Regards,

Thank you! That was one of the problems... Now we've got echo from the
kernel booting, other problems appears...

1. Cannot boot from NFS. Ok, we'll boot from MMC and take a look in another
moment.

2. The omap2plus_defconfig has the options about omap_fb and Alsa marked as
a modules. So we got...
modprobe: FATAL: Could not load
/lib/modules/3.4.0-rc4-00135-g2300fd6/modules.dep: No such file or directory

Well, you can change them from modules to built-in... Did you install
the modules to your rootfs, that would solve many of the errors shown
below..

Together with the followings other errors:

Error opening /dev/fb0: No such device

[...]

ALSA: Restoring mixer settings...

/usr/sbin/alsactl: load_state:1610: No soundcards found...

Configuring network interfaces... ifconfig: SIOCGIFFLAGS: No such device

ifconfig: SIOCGIFFLAGS: No such device

eth0 No such device

ifconfig: SIOCGIFFLAGS: No such device

ifconfig: SIOCGIFFLAGS: No such device

ifconfig: SIOCGIFFLAGS: No such device

usb0 No such device

ifconfig: SIOCGIFFLAGS: No such device

done.

[…]

Running /usr/share/ti/gst/omap3530/loadmodules.shFATAL: Module cmemk not
found.

FATAL: Module dsplinkk not found.

FATAL: Module lpm_omap3530 not found.

FATAL: Module sdmak not found.

These are from TI's SDK, did you rebuild them?

done

open /dev/fb0: No such file or directory

open /dev/fb0: No such file or directory

expr: syntax error

Linux Frame Buffer Device Configuration Version 2.1 (23/06/1999)

(C) Copyright 1995-1999 by Geert Uytterhoeven

Usage: fbset [options] [mode]

Valid options:

General options:

[…]

FATAL: Module omaplfb not found.

FATAL: Module bufferclass_ti not found.

These are from the TI Graphics SDK...

Hello, Robert. Thank you for your reply.

Yes, I changed from module to built-in. Please, read the point 3 of my
previous post.

Your post is a mile long..

modprobe: FATAL: Could not load
/lib/modules/3.4.0-rc4-00135-g2300fd6/modules.dep: No such file or directory

try "sudo depmod -a"...

Regards,

hi
check this link once :
http://www.youtube.com/watch?v=zJVJ9gXj3Wk&feature=plcp
kernel 3.4.0 ported on beagle board
blog :
arm9-mini2440.blogspot.in
best wishes

ooooh, someone ported the kernel to a platform that has been already supported for years in mainline! call the news!