Compiling RTL8192CU USB Wifi driver

I'm having a newbie problem (natively) compiling the Realtek RTL8192CU
wifi module on my rev C4 Beagleboard. I'm running the demo Angstrom
image, and I get the following when I run the included compile/install

Authentication requested [root] for make driver:
make ARCH=armv7l CROSS_COMPILE= -C /lib/modules/2.6.32/build M=/home/
rtl8192CU_linux_v2.0.1212.20101208 modules
make: *** /lib/modules/2.6.32/build: No such file or directory. Stop.
make: *** [modules] Error 2
Compile make driver error: 2, Please check error Mesg

I guessing I'm missing some headers necessary to carry out the
compilation? Are there any packages I can download to setup the
necessary framework, or do I have to download the raw source?



The standard r8192s driver included doesn't work?

I've installed the kernel-module-r8192s-usb package, but haven't had
any luck getting it to work. The USB device itself is recognised...

[ 19.126495] usb 1-2: Product: 802.11n WLAN Adapter
[ 19.131561] usb 1-2: Manufacturer: Realtek
[ 19.135681] usb 1-2: SerialNumber: 00e04c000001

And I can manually load the module r8192s_usb module, but still no
device appears under iwconfig. I tried following the instructions
- but again, no joy. I'm not sure if this driver supports 8192CU
devices as is? That's why I'm having a go at getting the non-free
Realtek drivers working.

  -- David