Completely disable screensaver


we’d like to run the BBB in an embedded application with display but without keyboard/mouse. Unfortunately it keeps blanking the display after a few minutes, even when I’m logged in remotely. I’m pulling my hairs out over how to disable it. I’m currently using

setterm -blank 0 -powerdown 0
xset s off

but it still turns off after several minutes. There also does not seem to be any way to wake it up again without using a physical keyboard/mouse?? I’m using the stock Angstrom image.

There is some FAQ stuff related to this (link below). If you try it, could you report back? This was an issue for me a month or so ago, but I moved on to other things and have not had a chance to play with this.


I too need to have the HDMI output not blank out, and am having problems. Using the link that you provided, I did the following:

  • I went to /media/BEAGLEBONE where /dev/mmcblk0p1 was mounted.
  • I edited uEnv.txt changing it from:

optargs=quiet drm.debug=7


optargs=quiet drm.debug=7 consoleblank=0

then rebooted the system. To my dismay, after ten minutes, the HDMI output still blanked out.
(I also tried adding consoleblank=0 with double quotes around it as shown in the provided link, but no luck.)

I did discover that the other part of information from that link does work.

When SSHed into the BBB, issuing this command:

echo 0 > /sys/class/graphics/fb0/blank

does take turn the HDMI output back on.

Did I do something wrong with that consoleblank=0 line in uEnv.txt? I also tried adding it to the uEnv.txt file in the /boot partition.



Try this, and let me know if it works.

This will also work

Thanks Cody, that did the trick!

My xorg.conf already had a “Monitor” section with that identifier, so I just added the “DPMS” option to it, then added the “ServerFlags” section.

Now the HDMI output stays on.



Hi, I have tried this on my Beagle Bone Black, but it doesn’t work. I’m assuming it’s because I’m not using the HDMI port. Instead I’m using 4D Systems 4DCape-43 Touchscreen. Do you have any advice or ideas on how to get this to work?

I am running on 4DCape43 LCD on Debian BBB and added

xset -dpms
xset s off

to .xsessionrc file in user’s home directory and this prevents my LCD from blanking after a period.


Hi All,

Just for the reference:

I’m using the console image for the beaglebone black ( bone-debian-8.7-console-armhf-2017-01-30-2gb.img ).

For the hardware I’m using:BeagleBone Black Industrial + 4D systems 4.3 display.

I was having the same problem:

  • Display blanks after 10 minutes.

  • Changing X11-settings doest not help (due to the fact that X11 is not installed).

I have found that :

echo 0 > /sys/class/graphics/fb0/blank

This turns the display back on, but only for a short amount of time.

It can also be done by:

sh -c “TERM=linux setterm -blank 0 >/dev/tty0”

But it is not a permanent solution, after a reboot the problem is back again, the display will blank after 10 minutes.

Editing /uEnv.txt seems to hold the solution.
add consoleblank=0 to the mmcargs line (see example below):

mmcargs=setenv bootargs console=tty0 console=${console} consoleblank=0 ${optargs} ${cape_disable} ${cape_enable} root=/dev/mmcblk0p1 rootfstype=${mmcrootfstype} ${cmdline}

Then after saving: Reboot the system and for me the problem has been solved (I’m now running for 25 minutes).

With the following command:

cat /sys/module/kernel/parameters/consoleblank

You can check if the value is indeed 0 (originally it was 600) => 10 minutes.

Best regards,

Hey Carl,

thanks for your suggestions. I´m struggeling with the same problem right now.
My /boot/uEnv.txt doesnt contain the mmcargs line. Where did you find it?



Hi Max,

There are multiple uEnv.txt files :

root@TestDevice:~# locate uEnv.txt








The correct file is /uEnv.txt

root@TestDevice:~# cat /uEnv.txt

##These are needed to be compliant with Angstrom’s 2013.06.20 u-boot.






##These are needed to be compliant with Debian 2014-05-14 u-boot.

loadximage=echo debug: [/boot/vmlinuz-${uname_r}] … ; load mmc 0:1 ${loadaddr} /boot/vmlinuz-${uname_r}

loadxfdt=echo debug: [/boot/dtbs/${uname_r}/${fdtfile}] … ;load mmc 0:1 ${fdtaddr} /boot/dtbs/${uname_r}/${fdtfile}

loadxrd=echo debug: [/boot/initrd.img-${uname_r}] … ; load mmc 0:1 ${rdaddr} /boot/initrd.img-${uname_r}; setenv rdsize ${filesize}

loaduEnvtxt=load mmc 0:1 ${loadaddr} /boot/uEnv.txt ; env import -t ${loadaddr} ${filesize};

check_dtb=if test -n ${dtb}; then setenv fdtfile ${dtb};fi;

loadall=run loaduEnvtxt; run check_dtb; run loadximage; run loadxrd; run loadxfdt;

mmcargs=setenv bootargs console=tty0 console=${console} consoleblank=0 ${optargs} ${cape_disable} ${cape_enable} root=/dev/mmcblk0p1 rootfstype=${mmcrootfstype} ${cmdline}

uenvcmd=run loadall; run mmcargs; echo debug: [${bootargs}] … ; echo debug: [bootz ${loadaddr} ${rdaddr}:${rdsize} ${fdtaddr}] … ; bootz ${loadaddr} ${rdaddr}:${rdsize} ${fdtaddr};


Best regards,