config-pin conflict on hdmi, hdmi is disabled

Hi All :slight_smile:

Cannot get config-pin to work on HDMI Pins even though HDMI is disabled, any tips/know how would be appreciated.

In /boot/uEnv.txt I have uncommented the
##BeagleBone Black: HDMI (Audio/Video) disabled:
dtb=am335x-boneblack-emmc-overlay.dtb

cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=enable

Working fine
config-pin P9_27 gpio_pu

Not Working
config-pin P8_45 gpio_pu

P8_45 pinmux file not found!
cape-universala overlay not found
run “config-pin overlay cape-universala” to load the cape

P8_26 <-> P8_46 same error (LCD/HDMI line)

I am running Debian GNU/Linux 8.8 (jessie) uname -a Linux beaglebone 4.4.54-ti-r93

config-pin overlay cape-universala

config-pin overlay cape-unversalh

dmesg output

[ 497.778959] bone_capemgr bone_capemgr: part_number ‘cape-universala’, version ‘N/A’
[ 497.779039] bone_capemgr bone_capemgr: slot #5: override
[ 497.779082] bone_capemgr bone_capemgr: Using override eeprom data at slot 5
[ 497.779132] bone_capemgr bone_capemgr: slot #5: ‘Override Board Name,00A0,Override Manuf,cape-universala’
[ 498.006318] bone_capemgr bone_capemgr: slot #5: cape-universala conflict P8.3 (#4:univ-emmc)
[ 498.014867] bone_capemgr bone_capemgr: slot #5: Failed verification
[ 516.664001] bone_capemgr bone_capemgr: part_number ‘cape-unversalh’, version ‘N/A’
[ 516.664052] bone_capemgr bone_capemgr: slot #6: override
[ 516.664075] bone_capemgr bone_capemgr: Using override eeprom data at slot 6
[ 516.664102] bone_capemgr bone_capemgr: slot #6: ‘Override Board Name,00A0,Override Manuf,cape-unversalh’

Much Appreciate in advance.
MB.

Use U-Boot overlays,

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#U-Boot_Overlays

i have the main dtb + the cape-universal overlay setup to more cleanly
work with config-pin/etc..

Regards,

Dear Robert,

Thank You, for anyone looking here is my complete /boot/uEnv.txt, changed in bold

#Docs: http://elinux.org/Beagleboard:U-boot_partitioning_layout_2.0

uname_r=4.4.54-ti-r93
#uuid=
#dtb=

##BeagleBone Black/Green dtb’s for v4.1.x (BeagleBone White just works…)

##BeagleBone Black: HDMI (Audio/Video) disabled:
#dtb=am335x-boneblack-emmc-overlay.dtb

##BeagleBone Black: eMMC disabled:
#dtb=am335x-boneblack-hdmi-overlay.dtb

##BeagleBone Black: HDMI Audio/eMMC disabled:
#dtb=am335x-boneblack-nhdmi-overlay.dtb

##BeagleBone Black: HDMI (Audio/Video)/eMMC disabled:
#dtb=am335x-boneblack-overlay.dtb

##BeagleBone Black: wl1835
#dtb=am335x-boneblack-wl1835mod.dtb

##BeagleBone Green: eMMC disabled
#dtb=am335x-bonegreen-overlay.dtb

###U-Boot Overlays###
###Documentation: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#U-Boot_Overlays
###Master Enable
enable_uboot_overlays=1
###Overide capes with eeprom
#uboot_overlay_addr0=/lib/firmware/.dtbo
#uboot_overlay_addr1=/lib/firmware/.dtbo
#uboot_overlay_addr2=/lib/firmware/.dtbo
#uboot_overlay_addr3=/lib/firmware/.dtbo
###Custom Cape
#dtb_overlay=/lib/firmware/.dtbo
###Disable auto loading of virtual capes (emmc/video/wireless)
#disable_uboot_overlay_emmc=1
disable_uboot_overlay_video=1
#disable_uboot_overlay_audio=1
#disable_uboot_overlay_wireless=1
###Cape Universal Enable
enable_uboot_cape_universal=1
###U-Boot fdt tweaks…
#uboot_fdt_buffer=0x60000
###U-Boot Overlays###

cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=enable

#In the event of edid real failures, uncomment this next line:
#cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=enable video=HDMI-A-1:1024x768@60e

##Example v3.8.x
#cape_disable=capemgr.disable_partno=
#cape_enable=capemgr.enable_partno=

##Example v4.1.x
#cape_disable=bone_capemgr.disable_partno=
#cape_enable=bone_capemgr.enable_partno=

##enable Generic eMMC Flasher:
##make sure, these tools are installed: dosfstools rsync
#cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

uuid=8731d94f-f843-483d-ac8f-791800f1dbfb

Warm Regards,
MB