Configure Beaglebone to access usb0 from host PC. (Cannot ssh to beaglebone through USB)


I am using ubuntu 14.04 (from Robert Nelson) with a custom 3.15.10-bone8 kernel on Beaglebone Black. HDMI is disabled.
When I plug the board to a PC, Beaglebone powers up but the PC does not recognize that a USB device is connected to it. I have installed the drivers for network-over-USB which is recommended on too. Moreover, I cannot ssh into it using eventhough I have set up my /etc/network/interfaces.

ubuntu@arm $ ifconfig usb0
usb0 Link encap:Ethernet HWaddr d2:56:2f:23:1d:e2
inet addr: Bcast: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Is there some modules that I need to run or compile to Kernel to bring the client USB up? How should I configure the linux to be seen by PC when connected from mini USB?
Thanks for any help.

I have the same issue too.
Did you fix that problem?

Same Issue here.

You need g_ether.ko module. You can check it is loaded.

Find the modprobe here:

You've got to have it serve up an IP address if you don't want to
manually configure:

I have the same too. I echieved to work on Eclipse for work in Java. But next day, when I turn on the laptop, I have tried to connect with psftp or putty (open ) neither Eclipse, and I don’t have achieved it. I have failed. What can I do? Thanks. Note: The connection by browser works well. (Mozilla Firefox and 0K).



Hi Jason!
uname -r
right now I-m able to ssh to my beaglebone, I can ping but not or any other website, I tried with the modprobe and I got

root@beaglebone:/opt/scripts/boot# ./
SIOCSIFADDR: Invalid argument
Job for dnsmasq.service failed. See ‘systemctl status dnsmasq.service’ and ‘journalctl -xn’ for details.

typing journalctl -xe

root@beaglebone:/opt/scripts/boot# journalctl -xe
– Support: