connecting MS5803-14BA pressure sensor to BBB

Hello everyone! :slight_smile: I tried to connect an MS5803-14BA pressure sensor to my Beaglebone Black, and when i test i2c-1 (pins P9_19 and P9_20), the sensor’s address doesn’t appear on the memory map. My hookup is the following MS5803-14BA Beaglebone_Black GND → P9_1 3.3V → P9_3 SDA → P9_20 SCL → P9_19 I am using the latest Debian image on the BBB with the kernel version 3.8.13 My question is: Did i something wrong on the hookup or on the Beaglebone do i need to configure something to make the i2c probing correctly? Theoretically if i connected the sensor properly, then i should see its address on the Beaglebone. Can give me somebody an advice? Thanks :slight_smile:

Well, on the new Debian releases, P9.19 and P9.20 are mapped to i2c-2.
Did you look there?

— Graham

Hi Graham :slight_smile: Yes, I tried. On default I2C-0 and I2C-1. I2C2 was disabled by default and i enabled it when the Beaglebone was running with the “echo BB-I2C1 > /sys/devices/bone_capemgr.9/slots” command.
The sensor was connected to the board. And here is another question: if i enable the I2C2 bus real time on the board, should it see the sensor or the memory map, without restarting the board?

  1. június 29., hétfő 20:28:34 UTC+3 időpontban Graham a következőt írta:

Well, some suggestions and thoughts.

1.) In kernel 3.8, I think I2C Pins P9.19 and P9.20 report as I2C-1, so you should see the part on that bus.

2.) Make sure you have not swapped the SCL and SDA lines. Make sure that you are really connected to P9.19 and P9.20.

You should see activity on both lines with an oscilloscope when you are running an I2C probe. Make sure that you have

pull-up resistors on each line, so that the lines go high when idle

3.) If you have another I2C part, like an EEPROM memory chip, or an I/O Expander, wire that onto the bus and see if it works.

4.) Try a later version of Debian with the 4.1 kernel. 2015-06-19 or 2015-06-29. These have the latest cape manager installed,

and they boot with P9.19 and P9.20 enabled as I2C-2. Although the “bone_capemgr.x/slots” stuff is not present.

5.) The MS5803-14BA has both SPI and I2C interfaces. Have you set the jumpers so that it is in the I2C mode?

— Graham