Connecting two ethernet ports via USB hosts..

Is it possible to connect 2 Ethernet ports via the USB hosts on the
beagle board ?... So that i get eth0 and eth1

usb0 , usb1

Hmm. Might be possible.
Although depending on need, one can assign multiple static ips to the same interface.

There is no reason you could not have multiple ethernet USB ports
connected to the board - the only limit will be the total bandwidth of
the USB interface.

You will definitely need a externally powered HUB to support this as
you will exceed the on-board USB current limit and the hub will act
somewhat as a data buffer too :slight_smile:

Thank you very much for your valuable suggestions. Let me give you an
introduction for what i want to achieve .
I will be running a self made GUI for iptables and routing useful for
Network Administrators (will upload after further testing), who are
reluctant to command line interfaces and using terminals.
This is basically used with systems having more than 1 ethernet port.
One is used for input from ISPs and other is used to route the
internet packets to and from the internal network.
So my question is will assigning multiple static IPs to same interface
do my job or do i need to purchase an externally powered HUB ?

If you actually want your iptables rules to be manipulating packets, and most importantly blocking certain packets, then you definitely want multiple physical interfaces. If you are just creating accounting details with your iptables rules, then it’s possible to do all sorts of things with a single interface. I’ve not spent much time building iptables chains in recent years. I used to configure firewalls and VPN solutions on a regular basis.


Okay can someone please suggest me what good external ethernet hub
does the BeagleBoard users prefer

The TRENDNET TU2-E100 has worked for my BB version C5.


I’ve been really happy with the Linksys USB300M. I’ve been working with the C4 revisions of the original beagleboard. It just plugged in and worked with Angstrom Linux, and then I’m still using it with no problems on my custom compiled kernel.

I thought I’d mention that the Linksys USB300M reports the following during a linux kernel 3.0 boot. I replaced the last 3 bytes of the MAC address with “*”.

[ 3.506774] usb 1-2: New USB device found, idVendor=0b95, idProduct=7720
[ 3.514831] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.522369] usb 1-2: Product: AX88x72A
[ 3.526336] usb 1-2: Manufacturer: ASIX Elec. Corp.
[ 3.532501] usb 1-2: SerialNumber: 000001
[ 4.371154] asix 1-2:1.0: eth0: register ‘asix’ at usb-ehci-omap.0-2, ASIX AX88772 USB 2.0 Ethernet, 00:25:9c:::**

I picked up 4 cheap ones - Pluscom SKU:U1EC, plugged one into the XM and the dm9601 driver in Ubuntu 11.04 automatically loaded. I configured it to suit a second network and both are OK.

Thanks a lot for all your suggestions I will be updating when I get
one to suit my purpose and test