Connection to board dropping / issues using udhcpc to get internet

Using Mac 10.6.8 and connecting my beaglebone via the micro usb → usb cable.The beaglebone appears consistently in my network panel as: RNDIS / Ethernet Gadget
Using terminal I see root@beaglebone.local* when I type ls in my home directory (and it is added to my known_hosts)
I am trying to share my internet connection through the Mac (a la: This has previously worked, and I had installed several c++ libraries and managed to compile a program.

Current problem:
The above internet sharing solution no longer works. When I ssh (ssh root@beaglebone.local) or screen (screen /dev/tty.usb*B 115200) into the beaglebone and call ‘dhcpc -i usb0’ it either hangs after ‘udhcpc (v1.19.4) started’ or tries to connect but never gets a connection.
If it hangs I cannot ctrl-c or ctrl-z out of the process… If I then close the window, and try to ssh in again I can not longer ssh into the beaglebone (despite it still appearing in my network). If it eventually times out:

Read from remote host beaglebone.local: Operation timed out
Connection to beaglebone.local closed.

Then I still can no longer ssh in, until I unplug it and boot again.

Things attempted:
At first I thought it was because of the wireless at my university (potentially needed to vpn in - which I tried). I also have tried on another wireless connection, with no such oddities, with the same issues. Then I thought perhaps it was the Angstrom and I had messed it up when installing stuff… but I have a second board that still has its factory settings that exhibits the same problems. Then I decided that it is that the connection from beaglebone to my computer does not stay up after the first few minutes… however, I waited for a few minutes after connecting and was still able to ssh in.

Any thoughts on if this is a udhcpc issue, a connection issue, a software issue, a hardware issue?

The only solution I found to this was to format the sd and uncompress the latest Angstrom distribution on it. Appears to work currently, I just hope it does not glitch out after a few tries…