I am using connmanctl to “try” to get into a valid configuration for WiFi for a BBBW. I am not successful yet. Does anyone have any pointers?


Hello Again,

I got far in my command for WiFi but I have no clue as to where to look for the dns_server, e.g. the last thing listed on my way to WiFi.


Hello Again,

ESSID: off/any

Encryption key: off

Power management: on

I set up a file to make sure my ESSID and Encryption key were used for setting up WiFi in a wpa.conf file. I reset the networking from intit.d and it resets. Then I command the system with ifup wlan0. I get a readout of Unknown interface wlan0. wlan0 is a Ethernet port for some reason. I have been unable to configure this port to make it a WiFi port.

I get no RX bytes and no TX bytes back or in rotation.



Hey Yo,

connmanctl is used as the initial command from

Then, you have to type in, while under the command connmanctl, wifi enable. While still under the connmanctl command, type in wifi scan and then type services. It will show your wifi_blah, blah, blah, blah, blah_blah, blah, blah_managed_psk Wifi address to type in once you type agent on and then connect. So you would type this under connmanctl:

wifi enable

wifi scan


agent on

connect wifi___managed_psk


You will be asked for a password. Enter the password you have for your router.

Done! I was taught this earlier today.


P.S. Enjoy!


I cannot enable wifi using connmanctl.

connmanctl can ot recognize wlan, only shows ethernet when technologies is asked.
May I ask you which image are you using ?



Sorry man. I just changed images. I will get back to you soon after I get a newer image. I am using the BBGW for now.


P.S. I will reply in about an hour or two. Sorry for taking so long to see this post.


How far do you get before something happens that does not get you to where you think you need to be?


P.S. When do things get going wrong? I just tried with the newest Stretch Flasher image from and it works.

Hey Again,

I am using an image from The flasher image called Stretch is what I used. I did not need to type, and this is after sudo connmanctl is entered in the prompt, wifi enable or wifi scan.


P.S. Get back to me. I may be able to help you.

As U stated in my case, it cannot see any wifi device.

So when i type wifi enable I get :

Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

I know the commands. But it cannot detect wifi.

So have a problem in linux.

Hello Again,

Did you try sudo instead of just connmanctl? If so, I am at a standstill. I have to use sudo connmanctl to run my set-up for the WiFi.


P.S. If you try a newer version of the listed images, I am sure it will work. You can skip the wifi enable and wifi scan if you use the newer images. You can start with services and agent on.

I think there are some other reports of issues with wifi networking on Stretch. It seems a kernel upgrade is required to fix it.

If you only have USB networking, you can use Cloud9 to upload the following files:

And do ‘sudo dpkg -i X’ on each of them to install.

I was able to do this, reboot, and then connmanctl started working for me again.

I’ll try to swap out the Stretch latest-images soon.

Let me know if updating the kernel doesn’t solve the issue.


I get the connmanctl cmd on the terminal working w/ the BBBW w/out using those listed files. I only have to use services and then agent on. I type my password and it works.


P.S. I am not sure about the other fellow, though. I have not heard from him.