cpu frequency scaling in Ubuntu?

Hi all,

I just grabbed and compiled the latest stable kernel for Ubuntu Lucid ( and cpu frequency scaling doesn’t seem to work like it did with the Angstrom kernel. Do I need to configure something more in the menuconfig to get this to work or is it unsupported at the time? I am using a XM A2 board and I just compiled with the default config file in the sources.



Nope nothing really extra to configure, the Angstrom Kernel has few
more special bits including the omap3 cpufreq driver which isn't in
mainline yet..




When I apply that patch and try to build I get an error: plat/opp.h: No such file or directory

Am I missing other patches? Sorry for these questions I’ve never tried to patch kernels before, only make my own changes.



Sorry about that Kevin, i wasn't verbose enough..

Your going to need more then just the patches i linked to, to make this work..

It would be just better to run Kevin's PM branch or the Angstrom
2.6.32-psp kernel till more of this stuff gets merged upstream...

I think this is Kevin's head pm test tree:



Hello Robert,
I was looking for a method to scale the CPU frequency on my BBxM
running Ubuntu Maverick (https://wiki.ubuntu.com/ARM/

Found this thread but the link given in the thread seems to be broken
and the method not working ( Kevin ?). I tried using cpufrequtils on
Ubuntu (as directed here http://www.thinkwiki.org/wiki/How_to_use_cpufrequtils)
but it wont load the BBxM processor drivers and hence doesn't works.

Can someone let me know a method using which I can run the BBxM at
1Ghz or atleast at a freq higher than the default one.


Hi Mrityunjay,

I'm getting closer to 1Ghz on the xM.. :wink:

Got frequency scaling to work this morning:
http://pastebin.com/wAe94bAt (300 -> 800Mhz steps)

Either from git head of my build script:

or the v2.6.38-rc5-d3 that are being built/uploaded to rcn-ee.net/deb/
right now..

it's 2.6.38-rc5 + Nishanth Menon's sr1.5 tree:

With this kernel, you can remove the "if xm limit to 800Mhz" setting i
had placed in the boot.scr, as mpurate=1000 doesn't hard lock the
kernel any more..

dmesg; [ 0.444610] Switched to new clocking rate
(Crystal/Core/MPU): 26.0/332/1000 MHz

I was kinda expecting the 300 -> 1,000 Mhz frequency options to show
up with the "cpufreq-info" probably missing one little detail....