Cross Compiling uboot - devkit 8000

HI,

i am using Devkit 8000 board, i recently cross compiled my u-boot source *'u-boot-1.3.3*' available in the TIMLL's provided CD.

i cross compiled using these steps,
*make CROSS_COMPILE=arm-none-linux-gnueabi- distclean
make CROSS_COMPILE=arm-none-linux-gnueabi- omap3devkit8000_config
**make CROSS_COMPILE=**arm-none-linux-gnueabi-** all*

and obtained the following error

*hello_world.c:1: error: bad value (armv7a) for -march= switch
make[1]: *** [hello_world.o] Error 1
make[1]: Leaving directory `/home/dcsystem2/Desktop/tmp_usage/u-boot-1.3.3/examples'
make: *** [examples] Error 2

*what could be done to get the uboot compiled.

Regards,
Prabu.J

Because the TimLL’s U-Boot 1.3.3 is very old,
I guess you need a old version of ARM cross compiler.

In my experience,
1.3.3 is fail to be compiled with arm2009q3, arm2010q1
(I means CodeSourcery G++ Lite),
but can be compiled with arm2007q3 only.

2010/5/26 prabu <prabu.jkmr@gmail.com>

hi,

Thank you for your reply, where can i get the latest uboot supporting Devkit8000.

Regards,
Prabu.J

林俊良 wrote:

I used latest Das U-Boot for DevKit8000
Website:
http://www.denx.de/wiki/U-Boot
Download release version source tarball:
ftp://ftp.denx.de/pub/u-boot/

And you also need newer version of linux-omap kernel
or you will not get to boot.
website: http://gitorious.org/devkit8000
get source by git plz…
$git git://gitorious.org/devkit8000/linux-omap-devkit8000.git

I used CodeSourcery G++ Lite arm2010q1.
And some commands for build:

Make u-boot.bin

cd u-boot-2010.03/
ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-
make CROSS_COMPILE=arm-none-linux-gnueabi- mrproper
make CROSS_COMPILE=arm-none-linux-gnueabi- devkit8000_config
make CROSS_COMPILE=arm-none-linux-gnueabi-

result: ./u-boot.bin

Make uImage

cd linux-omap-devkit8000/
ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-
make distclean
make ARCH=arm devkit8000_defconfig
make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- uImage

result: ./arch/arm/boot/uImage

2010/5/26 prabu <prabu.jkmr@gmail.com>

2010/5/26 林俊良 <goldie.lin@gmail.com>

I used latest Das U-Boot for DevKit8000
Website:
http://www.denx.de/wiki/U-Boot
Download release version source tarball:
ftp://ftp.denx.de/pub/u-boot/

And you also need newer version of linux-omap kernel
or you will not get to boot.
website: http://gitorious.org/devkit8000
get source by git plz…
$git git://gitorious.org/devkit8000/linux-omap-devkit8000.git

sorry for a typo
$ git clone git://gitorious.org/devkit8000/linux-omap-devkit8000.git

hi,

I am trying to update the devkit8000 kernel, from the git repo.
After pulling the latest updates , I tried to build the kernel but it does not boot.

I use the openembedded generated toolchain, so CROSS_COMPILE is arm-angstrom-linux-gnueabi-

I build the uImage using

mkimage mkimage -A arm -O linux -T kernel -C none -a 0x80008000 -e 0x80008000 -n “Linux” -d vmlinux uImage

And the u-boot the is shipped with the board, U-Boot 1.3.3-svn (Feb 4 2010 - 15:16:04)
same for the x-loader.

The system is configured to load u-boot and kernel from nand and the filesystem from mmc

Booting kernel from Legacy Image at 80300000 …

Image Name: Linux
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 6675907 Bytes = 6.4 MB
Load Address: 80008000
Entry Point: 80008000
Verifying Checksum … OK
Loading Kernel Image … OK
OK

Starting kernel …

it stops here…

Thanks

Fabio

The problem is the old U-Boot and newer U-Boot send different mach-id to kernel.
Try to replace the shipped U-Boot 1.3.3 with newer Das U-Boot (latest 2010.06).
The Das U-Boot latest stable version source can be found at: ftp://ftp.denx.de/pub/u-boot/
The building commands ref.: http://elinux.org/BeagleBoard#U-Boot
e.g.:
make CROSS_COMPILE=arm-none-eabi- mrproper
make CROSS_COMPILE=arm-none-eabi- devkit8000_config
make CROSS_COMPILE=arm-none-eabi-
(compile with “Sourcery G++ Lite for ARM EABI”)

Btw, I didn’t use the mkimage tool for converting vmlinux to uImage, but just directly use “make uImage”.

2010/7/31 fabio ferrario <ferrario.f@gmail.com>

Thanks,

I’ll try it out this afternoon. I’ll still stick to arm-angstrom-linux-gnueabi…
Using the Makefile out of the git repo “make uImage” was not available that’s why I used mkimage

Fabio

Well,

this fixed the boot problem but I have now new issues with the u-boot environment.
I used u-boot from the git repo so

U-Boot 2010.06-00236-g7385c28 (Aug 03 2010 - 12:01:32)

can you post the environment for the 7" lcd?

Thanks

Fabio

check: http://gitorious.org/devkit8000/pages/Home
or mine:

$ vi boot.cmd

Thanks

these bootargs look familiar to me, the lastest u-boot has a more elaborated scripting in the environment that allows ( I think so … ) for multiple boot options at runtime
Using the boot.scr out of the MMC should work an I’ll go for it, although I have u-boot and the kernel in NAND and the filesystem on the MMC

Thanks

Fabio

Dear All,
I am also working on the devkit 8000 board.

please provide linux kernel information, I am using 2.6.34 kernel.i compiled with arm-linux-2009.

I got same result it’s not booted. I checked bdinfo(mach-id) in boot loader is differs from kernel.

so i loaded the u-boot.4.3 reload and boot the kernel.

saminath.