Custom BBB with DDR MT41K256M16TW-107 uboot issue

Hello everyone,

I have a custom board similar to the beaglebone Black but without eMMC and without HDMI and I replaced the Kingston DDR with Micron MT41K256M16TW-107. I use the uboot version 2017.11 and create the uboot with the following commands:

  • make CROSS_COMPILE=arm-linux-
    gnueabihf- distclean
  • make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- am335x_boneblack_defconfig
  • make CROSS_COMPILE=arm-linux-gnueabihf- -j4

I’ve tried to bring up the board and calculate the DDR values and add them to the ddr_defs.h. After enter “#define DEBUG” to the file ti_am335x_common.h, I see that the bootup stops at the DDR. Here a output from the booting and where it stops.


I2C: omap24_i2c_findpsc: speed [kHz]: 100 psc: 0xb sscl: 0xd ssch: 0xf
initcall: 8080ce1d
DRAM: initcall: 80801f79
initcall: 8080cbf7
initcall: 8080cbf7
initcall: 8080cbf7
initcall: 8080cf19
Monitor len: 000BA7E8
Ram size: 20000000
Ram top: A0000000
initcall: 8080cbd1
initcall: 8080cc01
TLB table from 9fff0000 to 9fff4000
initcall: 8080cbe5
initcall: 8080ce7f
initcall: 8080ccfd
Reserving 745k for U-Boot at: 9ff35000
initcall: 8080ccd5
Reserving 32896k for malloc() at: 9df15000
initcall: 8080cde5
Reserving 80 Bytes for Board Info at: 9df14fb0
initcall: 8080cbe9
initcall: 8080ccad
Reserving 216 Bytes for Global Data at: 9df14ed8
initcall: 8080cc5d
initcall: 8080ce83
initcall: 8080ce8f
initcall: 8080cf75
initcall: 80801f8f
initcall: 8080cea5

RAM Configuration:
Bank #0: 80000000 512 MiB

DRAM: 512 MiB
initcall: 8080cc49
New Stack Pointer is: 9df14eb0
initcall: 8080cbf7
initcall: 8080cdb9
initcall: 8080ce87
initcall: 8080cd61
Relocation Offset is: 1f735000
Relocating to 9ff35000, new gd at 9df14ed8, sp at 9df14eb0
initcall: 9ff41fb5
initcall: 9ff41fb9
initcall: 8080d0e1 (relocated to 9ff420e1)
dram_bank_mmu_setup: bank: 0
initcall: 8080d0b9%(relocated to 9ff420b9)
efi_runtime_relocate: Relocating to offset=9ff35000


Has someone an idea what I forget to modify?
I’ve also tried to bring up the board with an old angström image. There it stops in the bootup of angström. Therefore I think that it has to be a wrong configuration in the software/uboot.
Thank you for your help.

Best regards

log_am335x.txt (107 KB)

Could somebody give an advise please?

can u post your DDR timings from ddr_defs.h file from uboot.