DAHDI kernel building failure

Hi all,
I need to use dahdi (dahdi_dummy device) on my BB-xM.
Following http://www.voip-info.org/wiki/view/DAHDI and R.Nelson
suggestions I tried with:

mkdir svn_repo
cd svn_repo
svn co http://svn.digium.com/svn/dahdi/linux/trunk dahdi-kernel
cd dahdi-kernel

make ARCH=arm KSRC_SEARCH_PATH=/usr/src/linux_2.6.37-x2/ KVERS=2.6.37-

but the result is ever the same:
make -C drivers/dahdi/firmware firmware-loaders
make[1]: Entering directory `/home/riccardo/svn_repo/dahdi-kernel/
make[1]: Leaving directory `/home/riccardo/svn_repo/dahdi-kernel/
make -C /lib/modules/2.6.37-x2/build SUBDIRS=/home/riccardo/svn_repo/
dahdi-kernel/drivers/dahdi DAHDI_INCLUDE=/home/riccardo/svn_repo/dahdi-
kernel/include DAHDI_MODULES_EXTRA=" " HOTPLUG_FIRMWARE=yes modules
make[1]: Entering directory `/usr/src/linux_2.6.37-x2'
/home/riccardo/svn_repo/dahdi-kernel/drivers/dahdi/Kbuild:98: CPU
Architecture 'arm' does not support VPMADT032 or HPEC. Skipping.
  CC [M] /home/riccardo/svn_repo/dahdi-kernel/drivers/dahdi/dahdi-

scripts/genksyms/genksyms: 1: Syntax error: "(" unexpected
make[2]: *** [/home/riccardo/svn_repo/dahdi-kernel/drivers/dahdi/dahdi-
base.o] Error 2
make[1]: *** [_module_/home/riccardo/svn_repo/dahdi-kernel/drivers/
dahdi] Error 2
make[1]: Leaving directory `/usr/src/linux_2.6.37-x2'
make: *** [modules] Error 2

Executing genksyms:
-bash: ./genksyms: cannot execute binary file

Added many:
#include <linux/slab.h> and #include <linux/dmapool.h>

/drivers/dahdi/voicebus/voicebus.c:1202: error: implicit declaration
of function "pci_clear_mwi"
/drivers/dahdi/voicebus/voicebus.c:1835: error: implicit declaration
of function "pci_set_mwi"

Ok, I made those scripts (genksyms and some others requested while making dahdi) with

make -f $KSRC/Makefile clean
make -f $KSRC/Makefile oldconfig

make -f $KSRC/Makefile scripts/genksyms/

make -f $KSRC/Makefile prepare

Thus, I managed to make all → make install → make config DAHDI, but failed to load it:

root@arm:/# dahdi_cfg -vv
DAHDI Tools Version - 2.6.1

Notice: Configuration file is /etc/dahdi/system.conf
line 0: Unable to open master device ‘/dev/dahdi/ctl’

1 error(s) detected

root@arm:/# ls -la /dev/dahdi/ctl
crw-rw---- 1 asterisk asterisk 196, 0 Oct 19 01:36 /dev/dahdi/ctl

Originally there wasn’t any files in /dev/dahdi, those are made with

The same result I had both for Angstrom and Debian wheezy (KVER=3.2.30)

Does anyone happen to make DAHDI work on beaglebone?