date, reboot, No eth0

I just got my BBB. Some background, skip down a few lines for my actual problem - The web based tutorial doesn’t work and Cloud9 runs a single .js script successfully then stops responding. I began using the BBB with PUTTY and everything seemed great…

When I set the time/date with “date” I lose my eth0 connection on my next power cycle or reboot. I set date and then hwclock and then I have no ethernet until I press the reset button and it all starts again. I’m back at Jan 1 2000 but have access to the BBB. Sigh… Can someone please point me in the right direction? I’ve spent the last 2 days on this. Any help is greatly appreciated.

Time is not stored on the board. It has no battery backup. It gets reset on power cycles.


Search this group for ntpdate, and there is a post explaining how this can be fixed. Granted the real fix comes from stackoveflow so you could search there as well.

What I personally did to fix this myself was run an init script that calls ntpdate at boot time. However I run Debian as my OS on out BBB’s. systemmd I suppose would be the equivalent in Angstrom.

hmmm no idea why you would be losing your eth0 connection though. This is the stock image that came with the board ? have you made any changes to the system since ?

Also, if I power the board from the 5.5mm external power connector, eth0 doesn’t work either. I have to have USB power going to the board. If I connect both, the external power LED comes on and the BBB becomes noticeably faster. The external supply is definitely good. It is a solid state regulated 5V 3A power supply and I have checked the output voltage.

From external power, I can’t even ping the board. The eth0 status LED does flash, but I get no response.

Thanks to everyone for the replies.

Thomas, well we have two BBB’s

The one I use mostly, I have plugged into a USB 3.0 port. I netboot, so obviously the ethernet always works. The other BBB my buddy uses ( he actually bought both ) is plugged in via a 1A walwart power supply, and it always plugged in to an ethernet port. Yes, it does work too.

Point being though, something does not sound right. using barrel jack or USB power, you should have ethernet working. Now sometimes and seemingly when I make changes to boot files ( build / copy a new kernel image on the /boot partition ), or I make changes to uEnv.txt I have to power cycle the BBB a few times. I have no idea how this works, and honestly have no idea how the BBB could know that I’ve made changes to anything period. But there you are. Most of the time though, when I issue a shutdown now -r command, it’ll come right back up no problem.

This thing been buggy from the first minute I plugged it in. Should I just load a new image via the uSD card and start from scratch?

It probably could not hurt. Not exactly sure what you’re saying there, but I would write a bootable image to a uSD, boot off the uSD, toy around with it, and see if the problem persists. If it does it might be time for an RMA, but of course CCO would have to advise you on that aspect.

Hopefully it is just a bad image flash.


I re-flashed the eMMC with the factory image from a uSD card. The web tutorial began working. It did not read my BBB’s serial number before and now it does. Also, the buttons in the tutorial now work (flash LEDs, set date, etc). I still can not get eth0 to work when the BBB is solely connected to P1 external power. I’m going to try flashing it with the 2013.06.06 release and see what happens.

Only luck I’ve had so far - BestBuy had an unadvertised sale on SanDisk 16GB class 10 uSD cards. $39.99 on the shelf, $14.99 at the register.

Any time I “reboot”, the BBB stops responding via ethernet until I press the reset button or cycle the power. I even tried to skip ethernet and get wifi working but that’s been a dead end also.

I have over 20 hours into this thing since Monday and I’ve gotten nowhere.

I’ve sent an RMA request. I’ll post the results.

Sounds like a SW issue. Reset works. Not something that can be fixed via an RMA.


I’ve flashed it three times. It’s behaved the same way since it came out of the box. If you believe it’s a software issue, I’m all ears if you can point me in the right direction to fix it. eth0 still doesn’t work at all from external power.

Thanks again to everyone. I really appreciate the replies.

OK. Let’s go your way. File an RMA request and I will have the factory test the board. If they cannot get it to work, then they will fix the Hardware

If it is a SW issue, then we will have to have the SW people look at it. I am the Hardware team. I handle everything except the SW. That is left to all the SW developers out there. If I had a SW solution it would already be in the image that ships with the boards.