Debian 7.5: apt-get upgrade kills Beaglebone Black


I have a Beaglebone Black, on which I used a microSD card to install the image “bone-debian-7.5-2014-05-14-2gb.img”

All appeared to be fine, I successfully expanded the partition size to use the full card capacity, and configured the system to appear on the network, with full DNS and internet access working.

After an apt-get update/upgrade, which did not show any errors and downloaded/installed ~84 packages without incident, I run the command sudo reboot.

The system never comes back. The lights flicker for a second when power is plugged in, but then they stop and the CPU LED stays on full, no activity at all on the others.

If I remove the microSD card and allow the board to boot off it’s eMMC storage, then it all fires up just fine with default settings.

Additional: First time I tried this, I actually tried an install straight after the upgrade, and it complained about the file system being read-only. Then I rebooted, and it didn’t come back.

Does a package in the latest repo updates break the Beaglebone? Is there anything in the latest updates that creates some kind of boot-up prompt that I cannot see via SSH?

Any help is appreciated.


Nope, there shouldn't be anything.

Do you have a usb-serial adapter available to dump what's happening on bootup?


Not a USB-Serial, no. I tried plugging a micro-HDMI in to see what happens on a monitor. With the eMMC image it all boots up, I see the initial command line outputs, and then get the Beaglebone desktop.

When I plug the upgraded debian microSD card in, it doesn’t even bring up any text. It’s almost as though the upgrade somehow prevents the image from being booted.

I’m going to go through doing an upgrade on each package one at a time, and rebooting after each one to see where the problem lies.


I also had this problem, and can’t seem to find my serial adapter. (It was convenient the original BeagleBone had a built-in USB to serial…)

Did you figure out what caused it?