Debian 7.6 libstdc++ problem

Hello there,
I am using latest Debian on my bbb:

Distributor ID: Debian
Description: Debian GNU/Linux 7.6 (wheezy)
Release: 7.6
Codename: wheezy

I have compilled a test program on my PC using arm-linux-gnueabi-g+±4.7 and it works perfectly well on my Raspberry pi. When i try to run this program on bbb what i get is this message:

root@beaglebone:/home/debian/testy# ./bcm_test
./bcm_test: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

I did a system update and ugrade. I then installed libstdc++6-4.7-dev but this havent helped. When i try to apt-get install libstdc++ i get this message:

root@beaglebone:/home/debian/testy# apt-get install libstdc++
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘libstdc++6-4.3-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.3-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.6-pic’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.0-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.0-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-3.3-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.7-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.8-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.7-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-3.3-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.7-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++3.0-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.7-pic’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.1-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.1-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-pic’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.9-glibc2.1-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.9-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.6-dbg-armhf’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.5-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.5-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.2-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.7-dbg-armhf’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.2-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.10-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.6-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.6-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.6-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-armhf’ for regex ‘libstdc+’
Note, selecting ‘libstdc+±dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.3-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.6-dbg’ instead of ‘libstdc++6-4.6-dbg-armhf’
Note, selecting ‘libstdc++6’ instead of ‘libstdc++6-armhf’
Note, selecting ‘libstdc++6-4.7-dbg’ instead of ‘libstdc++6-4.7-dbg-armhf’
libstdc++6 is already the newest version.
libstdc++6-4.7-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libstdc++6-4.6-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-2 is to be installed
libstdc++6-4.6-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-2 is to be installed
libstdc++6-4.7-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-2 is to be installed
Conflicts: libstdc++6-4.6-dbg but 4.6.3-14 is to be installed
libstdc++6-4.7-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-2 is to be installed
Conflicts: libstdc++6-4.6-doc but 4.6.3-14 is to be installed
E: Unable to correct problems, you have held broken packages.

Im pretty confused right now. How can i get the proper version running? I would really aprichiate any help!

"gnueabi" wrong compiler for "armhf", grab a "gnueabihf"

Regards,

Hello there,
I tried with gnueabihf, i get the same thing :confused:

W dniu piątek, 18 lipca 2014 13:20:12 UTC+2 użytkownik RobertCNelson napisał:

What does the output of:

ldd ./bcm_test

Show...

Regards,

UPDATE: Nvm, it works… Finally… THANK YOU