Debian jessie snapshot 12-19 bug report.

Debian jessie snapshot 12-19 bug report. ‘auto wlan0’ does not start WiFi service

I am running Debian jessie snapshot 12-19 on a Rev.C BBB.
I am bringing up a Netgear WM-1100 USB plug-in, a commonly
recommended WiFi acceessory for the BBB. I am running from
a more than adequate power source, so some of the reported
power glitching problems when running WiFi are not the problem.

If I use /etc/network/interfaces to configure and enable the
WiFi USB hardware, then I get an error that wpa_supplicant did
not start. And once it fails, wpa_supplicant will not start
with later manual WiFi start attempts.

The common and recommended way to manage and enable WiFi network
interfaces on the BBB is to un-comment the ‘auto wlan0’
line, the dhcp line, and enter the SSID and password or passphrase.

If I configure the wlan0 by uncommenting dhcp and entering the
SSID and password only, but do not uncomment ‘auto wlan0’ and
start wlan0 after boot is complete by entering ‘ifup wlan0’ on
the command line, then everything works fine.

I think there is a dependency on the USB subsystem, which
comes up almost last in the boot process which is the problem.
wpa_supplicant needs the USB subsystem to talk to the WiFi USB
plug-in, and ‘auto wlan0’ is trying to start too early.

If I use a systemd .timer set for 30 seconds after boot to start
the WiFi, then all works fine. I am sure that if I figured out
what the correct dependencies are named, I could use a
systemd .service to start the WiFi.

— Graham