Debian Lenny armel on BeagleBoard update

Just to update everyone... Making some progress with building a
native kernel thru qemu, however i'm fighting gcc-4.3.1. (I'm just
starting another batch build, but attempting to build with lenny's
gcc-4.2 this time, it usually takes roughly 3-4 hours thru qemu on a
2.5Ghz athlon 64, so it's been slow progress.) I'm also seeing an
binutils ice when attempting to build the *deb files, kinda strange
since the make uImage still completes afterwards..

This patch [1] is needed for gcc-4.3.1 with it I've been able to get a
make uImage to complete. However during boot, the uImage [2] hangs
with irq errors, (might be gcc-4.3.1 related) I've been finding most
of the issues i've fixed have already been fixed upstream, what's the
best git kernel and tag currently available? (With a working .config
with frame buffer console support.) I'm currently using the tar.gz
posted on google code beagle board site, "2.6_kernel_revb-v2" since
this has worked in debian etch 'arm'.

If any one else is interested in attempting to get a native *.deb
packages, I'm also attaching my current debian build script. [3]

[1] gcc-4.3.1 patch:
http://www.rcn-ee.com/code/beagle/debian/lenny/2.6_kernel_revb-v2-debian-gcc-4.3.1-armel-v1.patch

[2] uImage: http://www.rcn-ee.com/code/beagle/debian/lenny/Linux-2.6.22.18-omap3/uImage

[3] deb_build.sh:
http://www.rcn-ee.com/code/beagle/debian/lenny/Linux-2.6.22.18-omap3/deb_build.sh

Thanks!

Note: Forgot to mention this procedure listed here http://elinux.org/BeagleBoardDebian
also works quite well with Debian lenny 'armel', to build a default
image. (just follow the lenny 'armel' directions where important).
However, you may have to rebuild qemu from trunk (arm eabi issues).
Ubuntu 8.04's will fail, Debian Lenny's will boot, but you may see
fsck lock ups..

Debian's Lenny gcc-4.2 was a success, this uImage [1] will correctly
boot, console & frame grabber. However, still no
kernel-image/kernel-header deb's, make-kpkg didn't except
CROSS_COMPILE=, like it normally did, trying another documented
approach, should know in 3 hours..

[1] uImage: http://www.rcn-ee.com/code/beagle/debian/lenny/Linux-2.6.22.18-omap3/gcc-4.2/uImage

First Debian kernel-image[1], kernel-headers[2] and uImage[3] are
ready for testing. All built on the beagleboard, no emulation (only
took 3-4 hours), with gcc-4.2 (gcc-4.3's uImage halts, shortly after
loading uImage from the mmc drive, could be C70 cap issues, haven't
had time to turn off the board to remove it.)

The kernel is based on the same git tree and patches [4] applied to
openembedded.dev's kernel r61..

Will be updating http://elinux.org/BeagleBoardDebian shortly.

[1] kernel-image:
http://www.rcn-ee.com/code/beagle/debian/lenny/2.6.26-omap1-oer61-test/linux-image-2.6.26-omap1-oer61_2.6.26-omap1-oer61-10.00.Custom_armel.deb

[2] kernel-headers:
http://www.rcn-ee.com/code/beagle/debian/lenny/2.6.26-omap1-oer61-test/linux-headers-2.6.26-omap1-oer61_2.6.26-omap1-oer61-10.00.Custom_armel.deb

[3] uImage: http://www.rcn-ee.com/code/beagle/debian/lenny/2.6.26-omap1-oer61-test/uImage

[4] Patches: http://www.rcn-ee.com/code/beagle/debian/lenny/2.6.26-omap1-oer61-test/patches/