debian on beagleboard, fails in connexion

i am trying to install debian on my BB , i m using this wiki
http://elinux.org/BeagleBoardDebian (Debian Squeeze)
i m not using qemu , i connect the BB with OTG and in my host's
network i set ( sudo ifconfig usb0 up 192.168.1.60/ sudo route add -
host 192.168.1.61 usb0)
in BB i choose manually configuration i give ( ip :
192.168.1.61,gateway :192.168.1.101 which is my host's ip for
eth0,dns :192.168.1.254 which is my host's dns) sometimes it connect
but
it fails in dhcp autoconfiguration and when i choose to get archive it
fails also. please Robert Nelson i need your help or anyone who have
tried debian

Sorry, I've never bothered to try that method. Some users on IRC have
been successful using usb0 and have added their comments to the wiki
for others to use.

All my setups use usb ethernet/wifi and zippy2 adapters...

Your other option is to use rootstock to create a basic image.

Regards,

WHAT I GET WHEN I TRY WITH OTG http://pastebin.com/kAKAqNxD
WITH WIRELESS ADAPTOR http://pastebin.com/VBQn57NA

WHAT I GET WHEN I TRY WITH OTG http://pastebin.com/kAKAqNxD
WITH WIRELESS ADAPTOR http://pastebin.com/VBQn57NA

Please read: http://www.emailreplies.com/

Specifically: emailreplies.com – How to write Email replies

Next time, i'm not replying...

thanks , i ve tried right now with a wireless adaptor but i get that
it needs the rt73.bin ,how to give that rt73.bin into initrd ?

I'm thinking something like:

http://elinux.org/Talk:BeagleBoardUbuntu#Staging_Section

fill in the blanks for the proper firmware package...

Regards,

i want to ask the use of qemu in your wiki , could you explain for me
why you use it "qemu" thanks again :slight_smile:

sorry Robert Nelson for not using email etiquette when i ve written to
you

thanks , i ve tried right now with a wireless adaptor but i get that
it needs the rt73.bin ,how to give that rt73.bin into initrd ?

I'm thinking something like:

Talk:BeagleBoardUbuntu - eLinux.org

fill in the blanks for the proper firmware package...

This got more complicated fast, but give the script embedded here a test:

http://elinux.org/BeagleBoardDebian#Debian_Squeeze

Regards,

Which wiki are you reading?

http://elinux.org/BeagleBoardDebian

Doesn't use qemu, we use a native install script called "debian-installer"

At on time the wiki did, but the native debian-installer is much more reliable..

Regards,

hi mr Robert
1/ i ve tried your script i have now the rt73.bin but ,i get the same
issue when i select wirless and i give my essid and wep then it tries
to connect dhcp "Configuring the network with DHCP" finally i get
Network autoconfiguration failed
2/ i ve never see this "
Continue the install without loading kernel modules? : <yes>

Partition disks: This partitioner doesn't have the inform.....? :
<yes>
Logical Volume Manager not available: <Continue>"
it comes after the connection is set?
3/ after using CC-beagle-v2.6.29-58cf2f1-oer44.1.uImage in the first
section of your wiki Development PC: Setup SD U-boot Partition then
you have used linux-image-2.6.32.6-x6.2_1.0lenny_armel.deb
4/ the debian try to have mirror archive ,what is that for ?
5/the uInitrd doesn t have any commands dpkg,apt,... so i have to use
a rootfilesystem which contain all this command ?
thanks very much for your help

regards,
Houssem Bahri

hi mr Robert
1/ i ve tried your script i have now the rt73.bin but ,i get the same
issue when i select wirless and i give my essid and wep then it tries
to connect dhcp "Configuring the network with DHCP" finally i get
Network autoconfiguration failed

it ctrl-alt-f2, hit enter, type dmesg what does it show?

2/ i ve never see this "
Continue the install without loading kernel modules? : <yes>

Partition disks: This partitioner doesn't have the inform.....? :
<yes>
Logical Volume Manager not available: <Continue>"
it comes after the connection is set?

Those are all normal, kinda documented at:
http://elinux.org/BeagleBoardDebian#Beagleboard:_netinstall

3/ after using CC-beagle-v2.6.29-58cf2f1-oer44.1.uImage in the first
section of your wiki Development PC: Setup SD U-boot Partition then
you have used linux-image-2.6.32.6-x6.2_1.0lenny_armel.deb

Yes, so what's the problem?

That oer44.1 uImage is tested with the 'debian-installer' released on
Debian Lenny's Release date, now way over a year ago...

Once you have a system up and running, I recommend a different kernel
for normal day to day operations..

4/ the debian try to have mirror archive ,what is that for ?

What?

5/the uInitrd doesn t have any commands dpkg,apt,... so i have to use
a rootfilesystem which contain all this command ?

The uInitrd just contains the necessary modules/firmware and a basic
small image to run "debian-installer" it serves no other purpose.

Regards,

hi , Mr Robert
thanks a lot it works now with my wireless adaptor , but i get an
error in "Install the base system" Debootstrap Error Failed to install
the base system
The base system installation into /target/ failed, what should i do ?
thanks a lot

regards ,
Houssem Bahri

hi
after this issue when i open the new partition created i find :
media , debootstrap,var, etc
when i reboot with the mmc on beagleboard i get [ 23.299102]
Warning: unable to open an initial console.
[ 23.305847] Kernel panic - not syncing: No init found.

regards,
Houssem Bahri