Debugger Listening on Port 15454?

I have been trying the demo JavaScript files and I keep getting the message

Debugger LIstening on Port 15454

when I run the js file and it not doing anything.

I have no idea what do. I’m using Cloud9. I bought the BeagleBone Black from Adafruit about 1 month ago.

I tried the example given on the main page below

var b = require(‘bonescript’);

var state = b.LOW;

b.pinMode(“USR0”, b.OUTPUT);
b.pinMode(“USR1”, b.OUTPUT);
b.pinMode(“USR2”, b.OUTPUT);
b.pinMode(“USR3”, b.OUTPUT);
setInterval(toggle, 1000);

function toggle() {
if(state == b.LOW) state = b.HIGH;
else state = b.LOW;
b.digitalWrite(“USR3”, state);

I also tried some simple addition examples and keep getting the same debugger message.



Is the USR3 LED flashing at a rate of once per second?

I have the exact same problem. I think my BeagleBone Black is not working, as I can’t connect by any means, i.e. terminal, etc.


Hit the little green leaf looking thingy on the bottom right before you run the js. That turns off the debugger. You can also just hit play on the debugger to get it going.

Sometimes in js it will error out the first time it runs. Just stop and run again and it should work unless u have a real software issue.

I’m running into the exact same problem. Were you ever able to solve this issue?


Yes, it was that I had to push the play button on the debugger. Also thanks for the information about how you disable the debugger.

hi guys, this thread really helped me with some n00b issues.

future reference for others - deactivate debugging as illustrated above, or even simple files won’t run.
also, all files must be save with the .js extension don’t just type a filename and hit enter…add the .js. if your code is uncoloured, then the file isn’t recognised as a javascript file. you’ll also receive the Permission Denied error when attempting to run it

i was stumped for days with those issues…was writing code in nano via Putty terminal and it worked fine, couldn’t grok why Cloud9 was stalling

Thanks, Brian!