Determining version of PRU Software Support Package Installed

I am trying to determine which version of the PRU-Sofware-Support-Package is installed on our BeagleBone Black Wireless development systems running Debian 4.19.94-ti-r68.

I have not found any markers in the /usr/lib/ti/ directories to indicate anything more than 5.0. And the manifest doesn’t mention the specific release as far as I can tell. TI says that 5.6 is the last release that fully supports Debian 4.19.94-ti-r68.

Is there a way to tell which release is installed?

I have tried a brute force method of just checking file dates of some key source files and differences between the files installed on our systems and the ones in the TI Git under version 5.6 (which I’d like to install since it’s compatible with Debian 4.19.)

How do I do that if I determine that I need to upgrade? The folders where the package is currently don’t have a local repo.

Sorry to be such a Linux neophyte, but I could really use some help here. We see some strange behavior with remoteproc and with unsigned int variables being overwritten randomly. I want to be sure we’re on the latest supported version.


TI only seems to bump the readme between releases…


@RobertCNelson I had the repo address. I just don’t know how to determine if I have version 5.6 locally.

I’m not a git expert but I tried

git status

on these directories




and neither one have a local repo. If they had, I was going to try

git diff

to find differences. Would that have worked?

But since there isn’t a local repo, if I make one locally would I just go into


and then execute

git init
git add *.*

there and then do the

git diff

Seems awful cumbersome and I’m not sure it would be correct to do it this way. As always, thanks for your help and patience!