Device Tree Overlay at Boottime

Hi there

My goal is to connect 16 PEC11 Encoders to the BeagleBone Black. I’m using this Library https://github.com/guyc/py-gaugette. And I’m running the newest debian on my beaglebone.

I created a new device tree overlay as Derek Moloy explained in this video https://www.youtube.com/watch?v=wui_wU1AeQc setting my used gpios to mode7 and I’ve also read this https://learn.adafruit.com/introduction-to-the-beaglebone-black-device-tree/device-tree-overlays article about exporting device tree overlays. But I don’t know how to manipulate the uEnv.txt correctly so that at Boottime my BBB uses only my DTO.

This is my uEnv.txt:

##Video: Uncomment to override:
##see: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/fb/modedb.txt
#kms_force_mode=video=HDMI-A-1:1024x768@60e

##Enable systemd
systemd=quiet init=/lib/systemd/systemd

##BeagleBone Cape Overrides

##BeagleBone Black:
##Disable HDMI/eMMC
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G

##Disable HDMI
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

##Audio Cape (needs HDMI Audio disabled)
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI
#cape_enable=capemgr.enable_partno=BB-BONE-AUDI-02

##Example
#cape_disable=capemgr.disable_partno=
#cape_enable=capemgr.enable_partno=

##WIP: v3.14+ capes…
#cape=ttyO1
#cape=

##note: the eMMC flasher script relies on the next line
mmcroot=UUID=fa05f7e9-337d-4eb2-bb58-5e2eee8baac7 ro
mmcrootfstype=ext4 rootwait fixrtc

##These are needed to be compliant with Angstrom’s 2013.06.20 u-boot.
console=ttyO0,115200n8

kernel_file=zImage
initrd_file=initrd.img

loadaddr=0x82000000
initrd_addr=0x88080000
fdtaddr=0x88000000

initrd_high=0xffffffff
fdt_high=0xffffffff

loadkernel=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${kernel_file}
loadinitrd=load mmc ${mmcdev}:${mmcpart} ${initrd_addr} ${initrd_file}; setenv initrd_size ${filesize}
loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdtaddr} /dtbs/${fdtfile}

loadfiles=run loadkernel; run loadinitrd; run loadfdt
mmcargs=setenv bootargs console=tty0 console=${console} ${optargs} ${cape_disable} ${cape_enable} ${kms_force_mode} root=${mmcroot} rootfstype=${mmcrootfsty$

uenvcmd=run loadfiles; run mmcargs; bootz ${loadaddr} ${initrd_addr}:${initrd_size} ${fdtaddr}
capemgr.enable_partno=DM-GPIO-Test

Explained here:

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#Loading_custom_capes

Regards,

thanks a lot Robert you made my day :wink:

For those who have the same problem as i had:

you have to open the file /etc/default/capemgr


and add 

**CAPE=DM-GPIO-TEST** 

restart your bbb and your Device Tree Overlay will be loaded at Boot