Devkit8000 and usb otg

Hi

I have a devkit8000, one from the first generation, 128mb, no usb
host. therefor I'd like to use the usb otg port. I remember it worked
with certain revision of .32 or .33 kernel but then it stopped
working. lsusb doesn't show anything. also there's no /sys/devices/
platform/musb* . has anyone made similar experience or has someone
even a solution? I've tried several kernel releases from the devkit8k
sources on gitorious up to the most recent one with different configs.
maybe I miss a important option...
thanks in advance
martin

Hello Martin,

can you send your .config please.

Thomas

Hi Thomas

can you send your .config please.

as the whole config is quite long, I've put it in a pastebin:
http://dpaste.org/OFZO/

does the otg work on your board? it is only a first rev issue?

cheers

Hello Martin,

is the plug in of the mini-usb connector on your board detected?

[ 126.875854] twl4030_usb twl4030_usb: HW_CONDITIONS 0xc0/192; link 1
[ 126.878967] twl4030_usb twl4030_usb: twl4030_phy_resume

yes if I plug out plug in at the board I get the kernel msg you
described ^. If I do it at the hub nothing happens

/martin