Different HARDWARE same Rev.

Isnt damaged, the non working eth board if flashed with a more updated debian image it works!

Did you try Robert’s suggestion?


Ehmm… i saw the /etc/network/interfaces and is standard should work,… now im making the udev change… i hope and pray

Where in Italy are you?


the udev rule don’t work, the one explained in the link:

no results, tick tack tick tack…

Near Milan

Strange.. add it..

or just run

/sbin/ifconfig -a

and we can see what's really going on..


MAny thanks Robert,

ifconfig -a showed the eth1!!! so from what i understood is sufficient to put an ifconfig -a in the rc.local, is it correct?

Are you planning to attend Maker Faire Rome this weekend? If you are, stop by the Arduino booth and say hello!!


And now a simple question come to my mind… why the eth0 is on my working board and in the other is showed as eth1? maybe is the mac address that the system learn as is a second network card…

so from what i see is impossible to scale an image flashing to multiple BBB without setting the eth interface… is it correct?

I think that if the board are the same the image run as the same way as ive done a time ago with same laptop model formatted with the same image all ran well…

btw Robert and Gerald , thanks for the fast support, ill try to make a script to handle this…

It will be beautiful to have the time to go there… ive got a work to do…

done with:

ifconfig -a
ifconfig eth1 ip

Yes, is possible cause all the board will see it as eth1…

That's where adding the udev rule works for me with both
ubuntu/debian... Not sure why it didn't exist in your image..


When Linux boots up, it assigns loads the various network drivers for each network device and assigns names “randomly”

IE eth0 is the FIRST ethernet device to initialize. eth1 is the SECOND ethernet device to initialize. Etc.

Because some people depend on eth0 always being assigned to the SAME network card, there are a number of different “systems” in place for linux to force this to occur. Most of them revolve around using a program called udev can detect very specific information about the card[mac address, hardware id, etc] and then force the name to be assigned that you want. See http://www.linuxfromscratch.org/blfs/view/development/chapter07/network.html for details.

This means if you take a “working” image of linux from one machine and copy it to another machine, eth0 can ONLY be assigned to the network interface from the original machine. So on your second machine, you may end up with eth1 instead of eth0 or none at all!

Depending on what distribution of linux you use[Ubuntu, Debian, Angstrom, Arch, etc] AND what version you are using - there will be installed some shell scripts that when you boot the system up will

  1. Check to see if network interface configuration file exists[the file which defines MAC Address N should be called eth0]
  2. If the file does not exist, it will automatically create one using the current configuration.

This means that you cannot “copy” an entire linux installation from one system and put it on another. You have to delete the network configuration file that was automatically generated, so that a new one will become automatically generated on the new system.

Other alternatives are to delete that file AND to disable those programs which automatically generate new files and just live with the possibility of “random” network device names.

The “difference” your referring to is that many of the different devices on the board are assigned unique serial numbers. The hardware is identical, it is the serial number which changes.

In fact if i use MAKEDEV i get “udev not found”

Im glad to see you explanation, now is solved… a doubt is left: How could the Sys Builder make image that boot always in eth0? might they use eth0 or wifi… IMHO

Wait, i mean, if i have an access point configured on the BBB, of course the interface file is needed, so i mean: Does the usb wifi dongle suffer of the same problem? cause i canno t know which letter will be assigned to a device, the device is choosen by me but is random assigned. So there are some operation that i need to do before every backup…
Tnx Garyamort.

I’m afraid my knowledge pretty much ends at knowing WHAT the issue is and a generalized way to solve it - but not the specifics for your case.

I only remember all of this because I ran across the same “issue” with running Ubuntu on virtual systems via Amazon EC2. I’d try to “clone” a working system to turn it into an EC2 image and when I booted a new copy[which received a new virtual ethernet card with a new MAC address] it would not work. I eventually figured out the specific steps to follow when creating an EC2 image to purge this information so they would work - but I honestly don’t know what exactly the “process” should be when dealing with the BBB. At the moment I only have one BBB so it doesn’t affect me.

Sorry I couldn’t be more help. :frowning: I just figured I’d try to explain it in some extra detail because it was quite frustrating/difficult to understand when I first encountered it[especially since this “feature” had not been in the previous version of Ubuntu I used at the time, so it initially felt like the new version of Ubuntu “broke” EC2].

No probs, you helped enough…