Difficulty in installing DSP libraries onto the BB-xm

Hi,
I am trying to install DSP related libraries onto the BB-xm. I am referring to the BeagleBoardUbuntu wiki page. But when I type

gst-inspect | grep dsp nothing happens. 
Please suggest something?

Thanks in advance!!

So without knowing the background and what you actually did, how are
we suppost to help?

Distro version, kernel version.. you ran my script from
http://elinux.org/BeagleBoardUbuntu#gst-dsp right???

Otherwise, the last time i tried it, it was actually pretty slow and
jerky.. If you want real dsp support, just use angstrom with dsplink.

Regards,

Hi Robert,
                I ran the same script that you are referring. Does that script works correctly or are there any modifications? Are there any other options to run video on BB-xm?
  Also when I am trying to run any .mp3 files there is no sound, can you help me out?

Thanks!

From: beagleboard@googlegroups.com [mailto:beagleboard@googlegroups.com]
On Behalf Of Robert Nelson
Sent: Tuesday, June 12, 2012 5:28 AM
To: beagleboard@googlegroups.com
Subject: Re: [beagleboard] Difficulty in installing DSP libraries onto the

BB-xm

> Hi,
> I am trying to install DSP related libraries onto the BB-xm. I am
> referring to the BeagleBoardUbuntu wiki page. But when I type
>
> gst-inspect | grep dsp nothing happens.
> Please suggest something?

So without knowing the background and what you actually did, how are we
suppost to help?

Distro version, kernel version.. you ran my script from
http://elinux.org/BeagleBoardUbuntu#gst-dsp right???

Otherwise, the last time i tried it, it was actually pretty slow and

jerky.. If you want

real dsp support, just use angstrom with dsplink.

Hi Robert,

DSPLINK was superseded by SYSLINK and the last kernel supported for OMAP3 is
V2.6.32. I'm working on getting SYSLINK working with V3.0.28 but supporting
any kernel after that requires IOMMU code changes in SYSLINK which happened
after V3.1.

Regards,
John

Regards,

--
Robert Nelson
http://www.rcn-ee.com/

-- To join: http://beagleboard.org/discuss To unsubscribe from this group,

send

SysLink is only available for OMAP4, not for OMAP3. And still, next
SysLink v3 is quite different from the current SysLink v2:

For more info about the different ipc/amp mechanisms:

http://elinux.org/BeagleBoard/DSP_Clarification

vmjl