Disable boot messages

I have a Qt app which launches automatically but some boot messages appear on screen before it starts up. How can I disable these boot messages?

I’ve tried

  1. editing /etc/systemd/system/getty.target.wants/getty@tty1.service and commenting out ExecStart.
  2. removing lightdm
  3. checking /boot/uEnv.txt, it doesn’t contain any “console” command ( https://groups.google.com/forum/?fromgroups#!searchin/beagleboard/disable$20screen$20boot$20message|sort:date/beagleboard/765LGQ4a0bY/_wqpId-7C3IJ )

Thanks,
James

uname -a
Linux beaglebone 3.8.13-bone67 #1 SMP Wed Sep 24 21:30:03 UTC 2014 armv7l GNU/Linux

Messages include…

[ 0.372552] omap2_mbox_probe: platform not supported
[ 0.527489] tps65217-bl tps65217-bl: no platform data provided
[ 0.614605] bone-capemgr bone_capemgr.9: slot #1: No cape found
[ 0.651712] bone-capemgr bone_capemgr.9: slot #2: No cape found
[ 0.688822] bone-capemgr bone_capemgr.9: slot #3: No cape found
[ 0.707546] omap_hsmmc mmc.5: of_parse_phandle_with_args of ‘reset’ failed
[ 0.741892] pinctrl-single 44e10800.pinmux: pin 44e10854 already requested by 44e10800.pinmux; cannot claim for gpio-leds.8
[ 0.753606] pinctrl-single 44e10800.pinmux: pin-21 (gpio-leds.8) status -22
[ 0.760896] pinctrl-single 44e10800.pinmux: could not request pin 21 on device pinctrl-single

uEnv.txt command line
cmdline=quiet init=/lib/systemd/systemd

Changed the uEnv.txt line to
cmdline=quiet loglevel=0 init=/lib/systemd/systemd
worked for me.