Disable UART1 Echo

Hello All,

I am working with the stock Debian distribution of Beagle Bone Black (rev C).
I run the following command to enable UART 1 :

echo BB-UART1 > /sys/devices/bone_capemgr.*/slots

and it works fine i.e. I am able to see ttyO1 listed in /dev and also able to transmit commands to a remote terminal.

However, when I send anything from the terminal to BBB, I observe that the same data is echoed by BBB back to the terminal! How do I disable this?

I went through the stty commands but nothing relevant there.

Thanks!

jimit210@gmail.com wrote:

[-- text/plain, encoding 7bit, charset: UTF-8, 26 lines --]

Hello All,

I am working with the stock Debian distribution of Beagle Bone Black (rev
C).
I run the following command to enable UART 1 :

echo BB-UART1 > /sys/devices/bone_capemgr.*/slots

and it works fine i.e. I am able to see ttyO1 listed in /dev and also able
to transmit commands to a remote terminal.

However, when I send anything from the terminal to BBB, I observe that the
same data is echoed by BBB back to the terminal! How do I disable this?

I went through the stty commands but nothing relevant there.

Isn't it 'stty -echo' to turn echo off?

My understanding is ‘echo’ for ssty is just to turn ON/OFF echo of input characters i.e. if ‘-echo’ flag is used it would just prevent the input characters I send via BBB from appearing on my screen. My problem is with the data that BBB receives. Everytime BBB receives a byte, it transmits back the same byte.

I shall keep looking.

jimit210@gmail.com wrote:

[-- text/plain, encoding 7bit, charset: UTF-8, 38 lines --]

My understanding is 'echo' for ssty is just to turn ON/OFF echo of input
characters i.e. if '-echo' flag is used it would just prevent the input
characters I send via BBB from appearing on my screen. My problem is with
the data that BBB receives. Everytime BBB receives a byte, it transmits
back the same byte.

I shall keep looking.

I don't follow what you're saying. The UART/tty 'receives' bytes from
whatever is connected to it, that's what 'input' characters are.

E.g. you have a terminal of some sort connected to the UART, what you
type on the terminal are the 'input' characters and they're echoed
back to the terminal as 'output' to the terminal (if echo is turned
on).

By characters you 'send via the BBB' I assume you mean they are sent
by a program of some sort to the UART, if so they are just 'output'
characters and you can't turn them off I don't think. What's the
point of sending them if you turn them off?

Hello Chris,

I am sorry for the confusion. Let me explain the setup and then elaborate the problem.

So I have two XBEE/Zigbee devices. One of them is connected to BBB UART1. The other is connected to my PC.
On BBB side, I use picocom terminal to transmit data. On PC side, I have the X-CTU GUI provided by XBEE to send data/monitor received data.

Now, when I transmit from BBB using picocom, I can see the data being properly received by PC side XBEE.
However, when the PC side XBEE transmits data, it receives back the same data after transmission. This is because, for some reason, the BBB on receiving a byte transmits (echoes) back the same byte.

Now coming to ssty, I believe the ‘-echo’ option with BBB shall only prevent any character that I type on picocom terminal from “appearing” there on the terminal screen.

I have resolved this now. Turns out it was a problem with the hardware “cape” that I had prepared to mount XBEE on BBB. The Rx/Tx pins were swapped due to oversight. Everything works fine now.

Thanks everyone!!

jimit210@gmail.com wrote:

[-- text/plain, encoding quoted-printable, charset: UTF-8, 79 lines --]

I have resolved this now. Turns out it was a problem with the hardware
"cape" that I had prepared to mount XBEE on BBB. The Rx/Tx pins were
swapped due to oversight. Everything works fine now.

It had to be something like that! :slight_smile:

I am seeing a similar issue. I am using a terminal program on my computer to send bytes to the BeagleBone over a usb-to-ttl converter. Each byte that I send from my PC is received correctly on the BeagleBone (seen via “catting” /dev/ttyO5 in my case) but I am seeing the BeagleBone respond with the same byte that I just transmitted. I have double checked my wiring from my usb-to-ttl converter and everything is correct. Any ideas why this could be happening?

Thanks

   I am seeing a similar issue. I am using a terminal program on my
   computer to send bytes to the BeagleBone over a usb-to-ttl converter.
   Each byte that I send from my PC is received correctly on the
   BeagleBone (seen via "catting" /dev/ttyO5 in my case) but I am seeing
   the BeagleBone respond with the same byte that I just transmitted. I

That's what it's supposed to do! When you send characters they are
(normally) echoed back by the remote system, you don't output them
locally. You probaby want to set NOECHO or -echo on the program in
the PC that's sending the characters.

Thanks that worked.

stty -F /dev/ttyO5 57600 -echo

Thanks,
Caleb Davis