Disabled Wi-fi by mistake, how do I get it going again?

I did a REALLY DUMB THING and need help, please.

I’m running a BBB Wireless running

Linux beaglebone 4.19.94-ti-r61 #1buster SMP PREEMPT Wed Mar 31 15:23:20 UTC 2021 armv7l GNU/Linux

I boot from an SD card regularly and the machine is powered from a 5V wall adaptor through the barrel connector.

I am not using Bluetooth so thought I’d disable it using connmanctl. So I started that and used ‘disable bluetooth’. No errors.

Then, in a stroke of absolute lunacy, I ran ‘disable wifi’ which of course disabled wifi and killed my connection. Now, when I boot from the SD card, I don’t get any wi-fi.

I can boot and mount the SD card but I don’t know how or what to edit to enable wi-fi again.

If I boot from the EMMC, wi-fi works fine.

Hello @WalterCEden ,

Seth here. Running connmanctl again w/ the required arguments should work.

Are you able to sign in still under the SD Card image?

Seth

Thanks. Since I can’t connect to it with wifi, I’ve been trying to connect over USB with no luck. I figured that if could get to it over USB, then 'enable wifi" should work.

Since I can’t get to when I boot from the SD Card, but I can mount the SD card, is there anything I can manually edit to do the same thing and get wifi running again?

Hello @WalterCEden ,

Seth here again. Hmm…I get what you are saying now. So, eMMC booting has WiFi enabled. The SD Card booting has WiFi disabled.

Try Serial.

Seth

P.S. If serial booting does not work, like w/ COM9 or something on Win, maybe I might be out of ideas. I get what you are saying now and I have not found an answer to this quarrel. But! Let me keep checking. I will be back once I figure out how to handle it.

I’ve never connected using serial and don’t know how to do that.

Is there any way to enable wifi by editing a file or something? What does connmanctl change with the “disable wifi” command?

Also, when it boots with the SD card, the BT led is solid on and the WL led is off. And the USR leds are all off. It’s like it’s hung up. Maybe that’s why I can’t connect via USB??

I’m starting to think that I am going to have to rebuild the OS on the SD card. Can I do that without erasing all my user files, etc.? I can boot from the EMMC, mount the SD Card and then access it to update the OS on it. Or edit the file that disables the wifi.

Walter

Hello @WalterCEden ,

If you want to keep files, you can always use sftp or scp to transfer files before installing a new image. Also…one could, and this is speculation as I do not try this too often or even that recently, use the S2 button on the BBB with the SD Card in, change /boot/uEnt.txt to # out or what is called comment out the required file to stop eMMC booting.

Then once that is done, you just boot w/out the S2/Boot button engaged and leave the SD Card in.

It should flash your eMMC to the SD Card.

It, in theory, grabs all of the files and OS image arguments and options and installs it to a particular SD Card (I think). I would back up your files firstly. Then, try this option.

Using a serial debug cable on TX/RX/GND should prove useful as it will pop up on your Win desktop as COMn or Linux machine as /dev/ttyUSBn where n is a value of some sort.

Seth

P.S. Now, I am sure other people may try other ideas. For instance, a script may have already been written to handle such a mix up but I can try first if it is necessary. Seriously, I will write an image to the eMMC, a SD Card, and follow what mistake you made, and then ultimately perform what I described above.

Let me know if I should try it first.

and…

Then, I can report back. The issue is that you have files to keep.

and me…

W/ a fresh image, I will have nothing to lose except a couple writes.

Please send in what exactly you did and I will copy such actions and try it out.

1 Like

So it’s fairly simple

I boot from the SD card
sudo -i and login
I think I was probably in the root directory then
connmanctl
disable bluetooth
disable wifi

That killed it.

@WalterCEden ,

Hello…so? Did you figure it out? So, you were in the root dir. and disabled the WiFi?

Seth

P.S. I take notes too, i.e. as I do not have all day to acquire such a shtick of computational power all the time.

I didn’t figure it out. I decided to do an update and didn’t have enough space on the SD card to complete it. In cleaning off the SD card, I made another boneheaded move and deleted my development folder! Most of it had been pushed to github so I didn’t lose much. Just the changes I had made right before I had disabled the wi-fi - a few hours of work.

It began to seem like the SD card might be a problem as none of my Beagle’s seemed to want to boot from that card at all. So, I decided it was time to build a new card and install updated versions of my toolchain, etc. that took just a few hours really, pulled my code from Github and got back to work.

I also made lemonade from lemons and carefully documented every step of the build.

I would still like to know how to enable wi-fi but I am thinking that I won’t’ make that boneheaded mistake again!!!

Hello Sir,

@WalterCEden … connmanctl:

services

agent on

connect

Enter password.

That should do it if you have connmanctl loaded correctly. I have a board over here I can review. The set up may be surprising to you, i.e. it was to me the first time I opened up the files.

Seth

P.S. I was unaware that you were building from scratch. That is not always so easy (from my perspective). Anyway, I am glad you are back up and running. Oh! I will flash an image to SD Card and eMMC on my BBBW. This way, if you let me know where you took the wrong turn on disabling WiFi, I can reiterate your step and then try to make the eMMC boot into SD Card.

For future ref with the Wi-Fi thing on the BB Wireless, here are a few links that should help:
https://www.digikey.com/en/maker/blogs/2017/how-to-setup-wifi-on-the-beaglebone-black-wireless
https://www.fis.gatech.edu/how-to-configure-bbw-wifi/
https://beagleboard.org/static/librobotcontrol/networking_wifi.html

Cheers,

Jon

Good resources. I use the GA Tech one whenever I forget the specific sequence. My problem was that I could not connect to the BBB Wireless at all so I couldn’t get to the point where I could issue these commands. I suspect the boot area of the microSD that I was booting from had become corrupt. The BBB would not boot from that card. It would boot from the EMMC just fine and I could mount the SD card and edit files on it. But I didn’t know what changes to make in the files on the card to get wireless to come up when I booted from the SD card. If connmanctl can be directed to a specific mounted storage device I might have been able to use that. I don’t know if it can do that though.

I’m a little late, but connmanctl settings are located at
/var/lib/connman/ethernet_8030dc735744_cable/settings
the ethernet_8030dc735744_cable will be different for your setup.
maybe it will help next time. GL

Never too late. This is useful information but I don’t think it would have helped in this situation. In my case, I think that the wifi hardware was disabled entirely. As if a driver wasn’t loaded or loading on reboot. I ended up turning lemons in to lemonade and did something I should have done a long time ago. I made a completely fresh install on a microSD and updated everything, including my toolchain, etc. Then I set that aside as my recovery master that I burn to the EMMC on my development platforms. I’ve been back in business a week or so now and all is good. And I will NEVER do a Disable wifi again! (I hope!)

1 Like