Disabling Flashing

I successfully downloaded a new Bullseye Snapshot, installed on SD Card and flashed to eMMC following these directions from the snapshot update page:

eMMC Flasher

Copy board specific configuration files, example:
sudo enable-beagle-flasher
sudo reboot

How do I now DISABLE the flasher from flashing if I insert a different SD card image?
I tried sudo disable-beagle-flasher but that does not compute.
I did check the /boot.uEnv.txt to ensure the last line is commented out, and it is (cmdline=init=…)

Hi @rfeyer , the flasher is ‘disabled’ on the target file system. It’s up to you, to ‘re-enable’ if you wish to flash “back”…


My apology, but I don’t understand “is ‘disabled’ on the target file system.”
Is there a file which allows a command to disable?
Again, anything I found on the web regarding a file to change, had to do with /boot.uEnv.txt. Is that the file you are referring to?
As for the ’ sudo disable-beagle-flasher’ command, does it change a local file? Or, is there another sudo command which can disable the flasher?

That command or function is not implemented in the current design:

The design is as follows:

A = microSD = Golden Base Image
B = eMMC = Blank Device

Customize Base Image (A)

  • Boot Device with A
  • Make User changes to Base Image on A
  • Enable Flasher (sudo enable-beagle-flasher) on A and Shutdown Device

Flash Blank Device (B)

  • Insert A into Device to be flashed on B
  • Power Device, wait for A to flash B and Shutdown
  • Remove A
  • Power Device, Base Image now running on B

At what point would you like to disable A?


Sorry, I don’t understand what that means either. I did, however, get the flashing working by the sudo disable… command; this is also what you have specified in your latest update.
No matter, though.
I would still like to know specifically: How can I stop BBB from trying to flash to eMMC if put a MicroSD with a working image in the slot?

Simple, don’t have the microSD in the slot at power up.

Wait for the eMMC to load, then insert the microSD, mount the partition and edit the “uEnv.txt” file in the microSD partition…

Or just reformat the microSD.

Once you enable the microSD to be a flasher, it will do everything in it’s power to flash the eMMC…


TY Again!
I will reformat and re-install XFCE and hope it does not flash again :slightly_smiling_face:

It worked on both accounts!

  • re-imaging a MicroSD stopped the flasher
  • your previous directions on installing KDE over XFCE also worked
    • SUPER slow on the BBB, but at least now I know I don’t want it; went back to XFCE

TY VM for your help!