Disabling HDMI - uEnv.txt file does not have disable HDMI line

Hello,

I would like to disable HDMI to use enhanced GPIO pins via PRU. In order to do that I did a quick search, and wanted to edit uEnv,txt, but in that file I do not have a line like this:

##Disable HDMI
optargs=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

Here is the uEnv.txt file I have:

##These are needed to be compliant with Angstrom’s 2013.06.20 u-boot.
loadaddr=0x82000000
fdtaddr=0x88000000
rdaddr=0x88080000
initrd_high=0xffffffff
fdt_high=0xffffffff
##These are needed to be compliant with Debian 2014-05-14 u-boot.
loadximage=echo debug: [/boot/vmlinuz-${uname_r}] … ; load mmc 0:2 ${loadaddr} /boot/vmlinuz-${uname_r}
loadxfdt=echo debug: [/boot/dtbs/${uname_r}/${fdtfile}] … ;load mmc 0:2 ${fdtaddr} /boot/dtbs/${uname_r}/${fdtfile}
loadxrd=echo debug: [/boot/initrd.img-${uname_r}] … ; load mmc 0:2 ${rdaddr} /boot/initrd.img-${uname_r}; setenv rdsize ${filesize}
loaduEnvtxt=load mmc 0:2 ${loadaddr} /boot/uEnv.txt ; env import -t ${loadaddr} ${filesize};
check_dtb=if test -n ${dtb}; then setenv fdtfile ${dtb};fi;
loadall=run loaduEnvtxt; run check_dtb; run loadximage; run loadxrd; run loadxfdt;
mmcargs=setenv bootargs console=tty0 console=${console} ${optargs} ${cape_disable} ${cape_enable} root=/dev/mmcblk0p2 rootfstype=${mmcrootfstype} ${cmdline}
uenvcmd=run loadall; run mmcargs; echo debug: [${bootargs}] … ; echo debug: [bootz ${loadaddr} ${rdaddr}:${rdsize} ${fdtaddr}] … ; bootz ${loadaddr} ${rdaddr}:${rdsize} ${fdtaddr};

What should I do to disable HDMI? Maybe it is not enabled by default? How can I check that?

Thanks

Oh, and here is the output of uname -r:

4.1.15-ti-r40

https://github.com/beagleboard/bb.org-overlays/blob/master/readme.md

Read section: "BBB compatibility issues:"

Regards,

Thank you so much Robert!

Hi, Robert

I’m trying to disable hdmi, and I got clue from this link :https://learn.adafruit.com/setting-up-wifi-with-beaglebone-black/hardware

It says that I’ve to do : - mkdir /mnt/boot

  • mount /dev/mmcblk0p1 /mnt/boot

but when I enter I got this , mount: special device /dev/mmcblk0p1 does not exist

i’m trying to find another reference about how to disable hdmi, but I got same information for most of them.

Can you help me…?

thanks…

Make sure you have your SD card inserted, that’s the device path to the SD card.