Disabling I2C1 on BBAI

Hi everyone,
I am trying to disable I2C1 (connected to the on board STMPE811 ADC) so that Linux is not recognizing it. My end goal is to use the PRU-ICSS to read from the ADC using the I2C bus.

I have been playing around with the following devices trees: am5729-beagleboneai.dts, bbai-bone-buses.dtsi and this overlay: BONE-I2C1.dts trying to write I2C1 status as “disabled” but I have not been successful yet, either I still see the two default i2c-buses or the board won’t boot correctly anymore (I am using 4.19.94-ti-r50).
Can anyone let me know how I can disable I2C1 ?

Thanks

Pierrick