ds1337 alarm not appear on beaglebone

Hello guys,

I’m trying to complete a power cape for the beaglebone so that i can turn off the board completely and turn it back on a specific time or if a button is press. I installed a ds1337 for rtc but the driver is not showing any alarm option, I checked on the linux repository and on 2009 alarm support was added for ds1337/ds1339.

I’m adding the rtc with this line:

echo ds1337 0x68 > /sys/bus/i2c/devices/i2c-1/new_device

and appears as rtc1, no problem i can read it and write it but no alarm.

any help, is welcome!

thanks on advance

Do you have the interrupt line connected to the bone from the RTC? How
do you have it configured?

On alarm, the interrupt line gets pulled by the RTC, provided you've
setup the registers to do so. You'll need to sense that to know that
the alarm has gone off and service the RTC if desired.


You replied only to me, I'm replying to you and the beagle list.

the interrupts are not connected to the BB but to a msp430 that
controls the switching on and off, the BB will monitor a flag from
the msp430 to poweroff. I thought that an alarm files should appears
somewhere on the /sys/bus/i2c/device/i2c-1/1-0068/ folder that linux
use to interact with the rtc

Why not just have the bone get the alarm and power itself off? Or why
not connect the RTC alarm interrupt to the PMIC and use it like a power
button? Then you can have the RTC alarm power you down or up.

I'm confused at what the msp430 is doing in there.


ok, sorry

the msp430 is there because i wanna make an acoustic recording station and the beaglebone while off still consumes some power(mA) and there some other stuff to turn off with it, if the msp430 turn off the system with a external load switch the power consumption while sleeping is on the scale of nA.

my bad for the delay answering, I didnt saw your quetion the first time
thanks for the help