DSP node create fail

I tried to run sample program from http://gitbug.com/felipec/dsp-dummy.
However, I got an error message "DSPNODE_Create faliled: 0x8000803d".

I think bridge driver is okay because pint test works well.
I've loaded base image by following command.
insmod bridgedriver.ko base_img=ddspbase_tiomap3430.dof64P

Also, omapzoom's dsp binaries like dmmcopy.out works very well.

Is there anyone to know how to figure out the problem?


Hi Brian,

The TI nodes are included statically in that base image, that might be
the reason they work.

I haven't tried with ddspbase_tiomap3430.dof64P, but with
baseimage.dof I need to dynamically load the node:
dynreg.out -r /lib/dsp/dummy.dll64P

Are you doing that?

Hi Felipe,

I used the baseimage.dof and i have loaded the dsp node (dummy.dll64P) too…

But i got the exact same error.

“DSPNODE_Create faliled: 0x8000803d”

  • Jesslyn

Are you able to load the ping node?

I had some issues with the dummy node but only when using 6.1.x
compiler tools, 6.0.x worked fine.

ping node works fine. dummy node doesnt. I am using 6.1.6. Could that be the problem ??

I will try with 6.0.21

Hi Felipe,

I got the same errors with 6.0.21. Can you share with which version of 6.0.x dsp-dummy worked fine…?


Hi all,

I was able to run dsp-dummy application on my BB. I tried several toolchain version but got luck with the below one.


Thanks to Felipe for his help