dtc syntax error

Dear all,

I am using the latest version of Debian on the Black:

“Linux beaglebone 4.4.30-ti-r64 #1 SMP Fri Nov 4 21:23:33 UTC 2016 armv7l GNU/Linux”

My dtc version is “DTC 1.4.1-g1e75ebc9”

I am using the “misc cape” board from WaveShare. They have provided several .dts files for the overlays. One of them is for enabling the I2C and is called " DVK531-I2C1-01-00A0.dts". The file can be compiled with no error and the .dtbo was copied to the /lib/firmware directory. I enable this overlay by editing the /boot/uEnv.txt file adding the line:“cape_enable=bone_capemgr.enable_partno=DVK531-I2C1-01”. But during boot up it shows the error message : “[ 3.554491] bone_capemgr bone_capemgr: loader: failed to load slot-4 DVK531-I2C1-01:00A0 (prio 0)”.

Thinking I might have done something incorrectly, I then tried to load the BB-I2C1-00A0.dtbo from the repo of bb.org-overlays and it can be loaded correctly. I then examined the contents of the two .dts and found that there are not much difference except two lines of include files: “#include <dt-bindings/board/am335x-bbw-bbb-base.h>” and
#include <dt-bindings/pinctrl/am33xx.h>”. I therefore added the two lines to the DVK531 .dts and try to compile but then I get the error : “Error: DVK531-I2C1-01-00A0.dts:13.1-9 syntax error
FATAL ERROR: Unable to parse input tree”. I tried that on the I2C dts from the repo and get the same error. Can someone please tell me what was wrong and why the dtbo wouldn’t load?

The .dts from WaveShare:



  • Copyright © 2013 CircuitCo