DWA-131 driver fail using beaglebone as wi-fi hostspot

I’m trying to create a wi-fi hostspot using a beaglebone black rev-C and DWA-131 nano wi-if adapter.

I followed this article to install the driver: http://www.linux-hardware-guide.com/2013-11-16-d-link-dwa-131-n300-usb-wifi-adapter

And this project do setup the hostapd: https://github.com/jekader/hostapd-rtl

But when I try to start I’m getting the following error:

Configuration file: /etc/hostapd/hostapd.conf
drv->ifindex=4
l2_packet_init: ioctl[SIOCGIFINDEX]: No such device
no br0 interface , let l2_sock_recv==l2_sock_xmit=0x0x51648
ioctl[SIOCSIWMODE]: Operation not supported
Could not set interface to mode(3)!
Could not set interface to master mode!
rtl871xdrv driver initialization failed.
rmdir[ctrl_interface]: No such file or directory

My hostapd.conf is:

interface=usb0
driver=rtl871xdrv
bridge=br0
ssid=NETWORK-NAME
channel=1
wmm_enabled=0
wpa=1
wpa_passphrase=NETWORK-PASSWORD
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
auth_algs=1
macaddr_acl=0

Hostapt version? Driver’s name or config?

ps: I’m not confortable because my network interface for the wi-fi is usb0 instead of wlan0. Is a driver issue?

Can you include the dmesg log? Are you sure br0 is how the adapter was named?

Hi,

I remove the brigde=br0, but the message still the same:

`

drv->ifindex=4
l2_sock_recv==l2_sock_xmit=0x0x51638
ioctl[SIOCSIWMODE]: Operation not supported
Could not set interface to mode(3)!
Could not set interface to master mode!
rtl871xdrv driver initialization failed.

`

The dmesg log is as attachment.

Thanks

dmesg.log (27.7 KB)

fyi:

Back in May 22, 2014, "wireless: rtl8192cu v4.0.2_9000.20130911" was
intergrated into the "3.8.13-boneX" tree and first released as
"3.8.13-bone55"

https://github.com/RobertCNelson/bb-kernel/commit/eb82d272f28d537ffb96011a2e561b40eddd9bc1

Your welcome to stay on "3.8.13-bone47" but upgrading to the "latest"
3.8.13: "3.8.13-bone79" might be easier..

Regards,

Robert,

I updated, but the error persist. I tried to use the default hostapd, but the erro still the same. Any other idea?

Is there another wifi adapter model more compatible with beaglebone?

Thanks.

Robert,

I updated, but the error persist. I tried to use the default hostapd, but
the erro still the same. Any other idea?

you need to use realtek's hostapd..

Is there another wifi adapter model more compatible with beaglebone?

What happens when you disable "hdmi/nhdmi" cape? :wink:

Otherwise fire up 4.1.12-ti-r28

Regards,